import image as planes

I have imported an image as a plane for reference.
brought a cube into the scene to start a model.
When I go to wire frame the image plane also goes to wire frame.
How do i set up the image plane to stay visible even in wire frame?

you have likely created 1 object while the other is selected and in edit mode
create your objects making sure you are in object mode

a better way to have a reference model is to go to the N panels [with mouse over 3D view]
and down to Background Images where you can set things up as you need.
ws

I may have to use background image But I thought Blender could display each object at the same time in a different mode.

Stay in textured display or in solid display (with “textured solid” enabled in the N panel -> display), select the object you would like to be in wireframe display , then in the Object panel, set its display type to “Wire”
http://i.imgur.com/s7mhJKR.jpg
This way you’ll still see your image as plane textured and you will be able to work on your model in wire

I think the best way is adding an empty object of type image


I agree with KINjO
When you have the image on an empty you can set it’s transparency to see through the picture a little when you need to, you don’t have to worry about changing a bunch of settings for things like editing in wire frame mode and doesn’t show up in the render so you don’t have to move things out of the way.
Of course it’s the only method i’ve ever used, so i’m just assuming that texturing a plane for an image would show up in the render, but… i’ve never tried that route.

Oh yeah, going to give that a try.