Import not working ???

Hey, I’m now trying to import some existing .X files and .3DS files, I press file > import > select Direct X or 3DS, and then select the file, and press import. But nothing seems to happen :confused: Any ideas ?

check your Blender control window for error messages. Not the UI, but the dosbox. That is where python puts out error messages as a console.


I have the same issue.

In the dosbox thingie it says:

Importing 3DS: “C:\location*”
finished importing “C:\location*” in 3.5102 sec.

*that is the actual location, but it’s too long to write down. ^_~

However, when I start up Blender, I’m also told I don’t have python installed and as a result some scripts might not run. If it is because of python, how do I install it? :slight_smile:

Thanks for your help!!



I finally got Blender to recognise Python. (Needed 2.4 instead of 2.5) But the .3ds file still doesn’t want to open. My steps:

  1. Open Blender
  2. File > Import > 3d studio (.3ds)
  3. Choose file
  4. Click on [Import 3DS]
  5. Click on [OK] for the image size constraint box. (I’m not sure what I’m supposed to do here, but I presumed default settings would be ok?)
  6. Blender sends me back to the main window, but the mesh doesn’t open.

According to the dosbox thing it has finished importing in 1.2458 seconds.


Thanks again!!



Try to zoom in on your object I found that out when importing a few objects myself today actually…so zoom in to your center or something the object may just be scaled down real small is all I think it is…

–leroi-- cheers…

Ahhh, the cube was distracting me from it. :slight_smile: I erased the cube before importing, and then I found the little tiny super mini man. Being zoomed out was indeed the problem!

Thanks a lot for your help!

Now I’m off to some more tutorial stuff about how to increase the size of objects and whatnot. Hope MrMark has also been helped by this? :slight_smile:




I always like to make my first post on a forum really err interesting.

I would like to import a 3ds file.
I have it selected in the directory structure (err… do I right click it or left click it? ).

Now what do I do? I’ve tried reusing the d rop down menu “Import 3ds” once I have the file selected, but I just get taken back to the main blender directory again.

Double clicking doesn’t work.

sorry for asking a stupid quesition :slight_smile:

But it should be easy to answer!

thanks in advance.


Ha! I just saw the import button on the rhs of screen! Seek and yeah shall find. :oops:

@headwax - I’m not exactly sure that I understand you, but to import a 3ds, go to ‘File/Import/3d Studio (.3ds)…’, then select your file, then click the Import 3DS button.

@MrMark - try looking in an outliner window to see if there are any new objects. I’ve had problems before where it imports an object, but not a mesh

Thanks for the quick reply dreblen!

I can see that button now. I missed it at first :frowning: