import problems

i have found some lightwave files online that i want to import into blender but when i do so texture mapping is lost, i also asked a friend with lightwave to export them form lightwave as .obj files in archives of images with .mtl s, when i imported this obj to blender(or he imported it back to lightwave) texture mapping had been lost. does anyone know how i can import .lwo files into blender without losing texture mapping, is there a free script or converter anywhere, i found one for making obj files from kerkythea xml files is there an equivalent for .lwo files.

also as a second export problem i have found that some of the files(only a few) that are .lwo which i wish to load in blender are also available in c4d max and fbx. is there a method for importing any of those without loss of texture mapping?

p.s. anyone who can show me a method of importing lwo files to blender without texture that works for me will get a link to my tutorial on exporting from sketchup to blender so you can use models from the 3d warehouse, i also offer this and perhpas an exclusive release of a model of mine to anyone who will convert them for me, BUT WITH TEXTURE MAPPING INTACT!

i warn you my computer is so cr*p that blender sometimes crashes for me when i import a 3ds file of over 10 Megabytes.

thank you.

i have added a poll please vote

When I export an lwo object with multiple uv maps as *.lwo from Modeler, and I import into Blender, both uv maps are preserved. I do have to apply the images once more, and turn on uv mapping, and select the correct uv map.

Same with Collada, but I do lose one of the uvmaps.

So the actual texture mapping should not be los, if uv mapping was used in the original. Merely a matter of re-applying the images with te proper uv map.

For automatic correct image map conversion, do the following:

  1. download Accutrans http://www.micromouse.ca/
  2. open the lwo object in accutrans. Make sure the image(s) display properly on the object.
  3. select file_>save with options.
  4. Choose Collada in the save file type area, and check “Copy TExtures”
  5. save the collada file in a new folder

The object is then converted to Collada and correct image texture maps.

Activate the Collada add-on in Blender, and open the object. You should have an object with correct image mapping.

JagdPanther, did it work for you? The above method only works with uv-mapped models, btw.

Sorry to resurrect an old thread, but I am having similar problems exporting from LW to Blender, I retain my UV map, but all my materials are not textured, regardless of if I convert to Collada or not using Accutrans. The separate materials are there, the UV map is there, but all materials in Blender 2.69 are just diffuse and I do not see how to “bring back” the correct textures.
I will point out, I am just learning Blender, so if there are some steps I need to do, please take into account my “newbie” state. :slight_smile: