Import Rhinoceros 3D files into Blender

add-ons

(Metin Seven) #21

Cool, thanks. I’ll pass this on to the MoI developer.


(Nomo) #22

Thank you for this add-on! Would this feature something along the lines of converting Rhino Named view to Blender camera?


(jesterKing) #23

Views and named views aren’t yet imported:


(mak485) #24

i could not compile rhino3dm.py, i compiled in ubuntu 18.04, but created rhini3dm.mo! importer in blender 2.80 installed but not enabling, showing error rhino3dm module missing. any help???
compiler used gcc in ubuntu.
Screenshot%20from%202019-01-05%2022-05-46


(jesterKing) #25

Can you update the link to your screenshot, or repost the screenshot?

Also, what compiler did you try to use? GCC? Clang?


(jesterKing) #26

What is the exact path you are showing in your screenshot? Those files look correct and the rhino3dm folder (i.e. module) is in a folder called site-packages. That looks promising, but you need to ensure you have copied it to a location where Blender 2.80 Python can see it.


(mak485) #27

python3 is finding rhino3dm, but blender not. module place automatically there.Screenshot2


(jesterKing) #28

Blender is compiled to use Python 3.7. On my Linux Mint 18.3 I used python3.7 build_python_lib.py in the src folder of the repo.


(mak485) #29

Seems my system broke with python 3.6 creating problem with other packages dependencies. i have to fix ubuntu 18.04 first. thanks for yr prompt reply.


(Nomo) #30

Has there been any progress made on importing cameras? I can’t seem to do it with fbx natively.


(jesterKing) #31

I haven’t looked at cameras yet, there is an open issue for it:


(lewnworx) #32

I get this when attempting to activate the add on in Blender prefs.

Blender 2.8 2019-02-08
Mac OSX 10.13.4


(kkar) #33

you are probabloy missing this step

“install rhino3dm.py by typing in the command prompt: pip3.7 install --user rhino3dm”


(lewnworx) #34

Ok, got that solved (painfully). Default python for macOS 10.13.x is 2.7 something.

Went to python, got latest (3.72), installed it and used pip3 to install the McKneel python library. Console shows:

It shows up in /users/me/library/python/3.7/lib/python/site-packages/rhino3dm.

Ok, so having done that, install the zip file in blender 2.8 and console shows:

Modules Installed () from '/Users/mark/Downloads/import_3dm-v0.0.2.zip' into '/Users/mark/Library/Application Support/Blender/2.80/scripts/addons'

Next try to activate it in the user prefs and I get this:

Traceback (most recent call last):
  File "/private/var/folders/2z/69lkvx6j1snbh6hlmc3ptwyh0000gn/T/AppTranslocation/FD3D1323-9308-4DBA-89EE-FB9C184AECC1/d/blender.app/Contents/Resources/2.80/scripts/modules/addon_utils.py", line 351, in enable
    mod = __import__(module_name)
  File "/Users/mark/Library/Application Support/Blender/2.80/scripts/addons/import_3dm/__init__.py", line 43, in <module>
    import rhino3dm as r3d
ModuleNotFoundError: No module named 'rhino3dm'

Any clue what I’m doing wrong here?

Thanks,

Mark


(lewnworx) #35

Ok, managed to get it to work.

Problem apparently is the “blender” python is NOT the same as the OSX installed or post manual installed Python. As a result, even though I was able to PIP install the rhino library, Blender on OSX could not see that install. Not sure why but I’m guessing it has something to do with gatekeeper and security wanting everything to run in it’s own sandbox.

I found another blender add-on that allows you to install via PIP to blender’s own internal python, and once I installed rhino3dm via the blender PIP add-on it allowed me to activate it and import a 3dm.

It works, mostly although everything I import comes in at 10x scale. (I typically run inches for units in Rhino, not sure if this affects things or not.

FWIW, I’ve never got stuff modeled in Rhino to come in at the right scale. It’s always either 10x or 100x larger than in Rhino model space. In the past I’ve exported as OBJ, but the same thing applies here.


(kkar) #36

Blender will use system’s Python if it cant find the python folder in its binary disribution, although I did not test this un OSX, it works that way in Windows.


(lewnworx) #37

No idea how it works under the hood.

Any clue as to why stuff’s coming in at 10x size?


(kkar) #38

No idea :slight_smile: I never used Rhino or this importer. My guess is something to do w units.


(lewnworx) #39

Something to do with Imperial vs. metric.

Set rhino up for inches, created a 1" cube, imported it, and with blender set to inches it shows as 39.3701", but when set to metric, it shows as exactly 1m.

Not sure. Guess I can leave it in metric and mentally track meters as inches…

Yeesh.


(jesterKing) #40

The unit conversion and scaling issue is still open and being worked on.