Import Rhinoceros 3D files into Blender

Nope, even with the restart of PC… this is the output inside Blender info.

Traceback (most recent call last):
  File "/home/pafu/.config/blender/2.80/scripts/addons/import_3dm/read3dm.py", line 113, in <module>
    import rhino3dm as r3d
  File "/home/pafu/.config/blender/2.80/scripts/addons/modules/rhino3dm/__init__.py", line 5, in <module>
    from ._rhino3dm import *
ModuleNotFoundError: No module named 'rhino3dm._rhino3dm'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/home/pafurijaz/.config/blender/2.80/scripts/addons/import_3dm/read3dm.py", line 106, in install_dependencies
    raise Exception("Failed to install rhino3dm. See console for manual install instruction.")
Exception: Failed to install rhino3dm. See console for manual install instruction.

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/home/pafu/Software/blender-2.80/2.80/scripts/modules/addon_utils.py", line 351, in enable
    mod = __import__(module_name)
  File "/home/pafu/.config/blender/2.80/scripts/addons/import_3dm/__init__.py", line 43, in <module>
    from .read3dm import read_3dm
  File "/home/pafu/.config/blender/2.80/scripts/addons/import_3dm/read3dm.py", line 117, in <module>
    install_dependencies()
  File "/home/pafu/.config/blender/2.80/scripts/addons/import_3dm/read3dm.py", line 108, in install_dependencies
    raise Exception("Failed to install dependencies. Please make sure you have pip installed.")
Exception: Failed to install dependencies. Please make sure you have pip installed.


Hmm, that sounds like the rhino3dm module didn’t install correctly.

Does it install correctly in your regular Python 3 install for your OS?

Maybe you can show the contents of the folder /home/pafu/.config/blender/2.80/scripts/addons/modules/rhino3dm

Yeah I think all was installed correctly via pip…

But my addons was installed in this folder /home/pafu/.config/blender/2.80/scripts/addons/

Below a screenshot of my folder…
immagine

Maybe I try to copy in the local folder of blender, not int the shared folder.

And here the screenshot of my local folder. /home/pafur/Software/blender-2.80/2.80/scripts/modules/
immagine

Not sure how that ended up like that. The rhino3dm module should be the folder ~/.config/blender/2.80/scripts/addons/modules/rhino3dm. And that folder should contain a init.py and a .so file

1 Like

here the content of my .config, but not works, and script continuously try to install the rhino3dm.

~/.config/blender/2.80/scripts/addons/modules/rhino3dm$ ls
__init__.py   __pycache__  _rhino3dm.cpython-36m-x86_64-linux-gnu.so
__init__.pyi  py.typed

Is that modules folder in sys.path in your blender Python console? Are you able to run import rhino3dm in that py console?

Inside blender I have an errors.

>>> import rhino3dm
Traceback (most recent call last):
  File "<blender_console>", line 1, in <module>
  File "/home/pafurijaz/.config/blender/2.80/scripts/addons/modules/rhino3dm/__init__.py", line 5, in <module>
    from ._rhino3dm import *
ModuleNotFoundError: No module named 'rhino3dm._rhino3dm'

But from console system its run, and I see a cursor changing in a cross pointer, but when I click around close automatically,

~$ import rhino3dm
import-im6.q16: not authorized `rhino3dm' @ error/constitute.c/WriteImage/1037.

You probably need to remove all rhino3dm related files and try to enable import_3dm as a regular user instead. No sudo.

Hi @guiggarcia,
I have followed your steps again on a fresh installation, in a different machine, only using the python core that comes with Blender 2.80, and the rhino3dm issue went away. However, now there is another issue with import3dm script and the use of curve.py. @jesterKing, do you have any clue what may be happening?


Thank you guys in advance!

You can edit the file mentioned at the last line (curve.py in said location). Modify line 99 to read:

CONVERT[r3d.PolyCurve] = import_polycurve

then save the file.

Restart Blender and you should have a working import_3dm.

Thank you so much, @jesterKing! And thank you for such a useful addon! :slight_smile:

Hi, I’m havin this problem, on two different machines. Any tips?

hello jesterKing, i download import_3dm-master.zip from https://github.com/jesterKing/import_3dm/tree/master/import_3dm, after i installed the zip file, the Addons not showing up on the addons lists. already follow the instructions from README.md… any idea??? thanks