! IMPORTANT: All animations overridden!

Okay, hello. So I’ve spent the past few days working on a game for finals in about 8 days, and I’ve been creating a view model to look at while playing. I animated an IDLE, WALKING, and RUNNING cycle. The problem? As soon as I attempted to import it into unreal engine I looked back at it and found that all my animations have been overridden with another animation. I did happen to use an experimental check box for Apply Transform to see if it would fix my importing issues. An interesting thing happens when I reopen blender though. It seems like the first animation I select is the one that overrides the other animations linked to my model. I’m actually starting to panic here, so I’d absolutely love it if somebody can help me with this.

Here’s the model: https://drive.google.com/open?id=1Y_PD6rIOnZQIQoiQV1JLs5CpKWqOWi8b

Here’s the last FBX I’ve created of it: https://drive.google.com/open?id=1iRjucYkFRXSt_AQlkp5MEywdTrgVU0Cs

How skeletal animation works:

  • the bones of the armature are animated
  • the bones deform the mesh
  • therefore the action should only be applied to the armature, not the mesh

The behaviour you described happens when you apply an action to the armature and then you apply a different action to the mesh. Then you say, OMG, I selected the run action and still the idle animation is played. The run action will do nothing to the mesh since it has only references to the bones of the armature but since it is not applied to the armature, and the mesh has no bones, it will not change anything.

I opened the fbx file and it shows the normals of the mesh inverted but the normals are fine in the blend file so it could be that experimental setting you mentioned. Don’t use it, instead, apply the subsurf modifier before export.

Your title:
Now this is just plain disrespectful to the others who ask for help. This suggests that you think that your issues are any more important than those of the others. You don’t want to come across as a spolied child so NEVER DO THIS AGAIN. For now, I’ll just attribute this to your being freaked out.

Hey! What do you know, It worked like a charm! Thank you

Also about the whole title I was extremely stressed as of then and I put that title so I could maybe get a quick response. I didn’t mean it as in my problem has more priority, just so I could quickly solve this. Not to mention it’s my first topic on here : P.

Again, thank you!