imported ms3d Mesh not show in Render

im new and in learning progress of blender. i have problem to render my model, its not show in the render , my model is imported from Milkshape 3D with ms3d file extension,anyone could help.

render, as you noticed the GIRL IS MISSING

3Dview


blender file: missingGirlmesh.blend (910 KB)

Sorry, but blender crashes every time I try to open the file.

for information im using Blender 2.64, and i install ms3d import export from : http://wiki.blender.org/index.php/Extensions:2.6/Py/Scripts/Import-Export/MilkShape3D_MS3D to import MS3D file

and after read your post i try re-download my own blender file at link above and i opened in blender with no problem.

Something is wrong with how the material is applied. When I tried to remove the material from the mesh, Blender crashes. But here’s how I was able to solve it: select the mesh, tab into edit mode. Go to the materials tab, click on the + button to add a new texture. Click Assign. Create a new material by clicking the New button. Your mesh should now appear white.
Now I went into the textures panel, deleted the texture, then back to the materials and deleted the material. Deleting the texture may not be necessary. However, after this, I was able to reapply the original material with no problems, and it rendered the mesh just fine.

WOW…thanks so much @nemoDaedalus, your method worked perfectly now i can be able to render that girl, but so strange i think… :eyebrowlift: And my last question:

  1. any difference, to set material from object mode and edit mode…? because i set the material in object mode. and the mesh has UVmap originally to display texture.

Just for information:

The render problem is a second problem to that mesh. The first problem is when i set material to that mesh after i import it, the mesh color in 3D view turn black. And i solved through blender display option and check the Textured solid option in shading section.

When applying the material in Edit mode, when you click Assign, it assigns the material only to the selected faces. Because deleting the material crashed Blender for me, I did this to assign a new material to the entire mesh first before deleting the other one.

I noticed it showed up as black in the 3D viewport, which is what led me to suspect something wrong with how the material was linked. I can’t remember, but after changing the material, it should be fixed too.

hello, it would be helpful, when you also use the “Report Bug” button of the add-on, to give the author the chance to fix that issue in the code.
yes, by myself, i also noticed that issue and i changed the assignment of materials already in the add-on. but i found that issue way later than you.