Imported OBJ file, no textures?

Ok, so this is what I’m doing:

  1. Downloaded a free OBJ file (of a house) from this site: turbosquid.com

  2. Imported the OBJ into Blender.

I can see the house, but there are no colors (I’m assuming the textures aren’t linked or something). I can see materials listed in the material view, and if I change their colors portions of the model update as well. And in the textures view, there are files listed, but they have no names or info.

Any thoughts? I’m a complete noob… so go easy.

Here is a link to the model: http://www.turbosquid.com/3d-models/house-obj/438709

  1. Downloaded a free OBJ file (of a house) from this site: turbosquid.com

Link to model ?

Of course!

http://www.turbosquid.com/3d-models/house-obj/438709

I just edited the original post with a link.

It appears that all the different materials have Transparency and Mirror active. For each material untick these checkboxes. You may want to keep then ticked for the window glass materials
You should also clean up the mesh, remove doubles (W / remove doubles) and recalculate normals (Ctrl+N). It also helps then to add an Edge Split modifier.
Modified blend file attached

Attachments


house.blend (1.37 MB)

Ok, you’re definitely correct. I unchecked all of them, but it made no difference as to how the model appears (?)

Ok, I think I’m getting closer. At least, in “Texture Mode” it looks great, but in Object Mode it still looks all black. When I render, I can see some texturing, but not all.

I’ve attached the blend file I’m working on. I compared it with yours, but can’t see what I might be missing :frowning:

house1.blend (1.02 MB)

So am I outta luck on this one? Either I’m missing something simple, or the version of Blender I’m using (2.57) has some kind of bug?

You see it black in Solid display mode because most of the materials have the diffuse color set to black for some reason :
http://i.imgur.com/Tj32h.jpg

Change this color to grey for every material that have it black and you’ll see the model better when not using Textured display mode

Thanks. This is all just really weird. For instance, even on a material where I change the diffuse color to grey, the material still shows as, say, orange, and the result on the house is grey. I guess I just don’t get this material stuff.

For instance, I’ve done as you said, and now my house just looks like different shades of grey (in Object Mode). Looks great in Texture Mode (although this hasn’t changed).

Any thoughts as to what I’m missing?

Furthermore, the rendered image is still almost completely black!

Ok, it renders with color now because I added another light. Oops.

But in Object Mode I still see no textures.

I think I figured it out. I had to display the Properties toolbar and select “Textured Solid.”