Imported Sketchup models slow Blender down to a crawl

I’ve been trying to use some models from 3D warehouse in my scenes, however many of them end up with an enormous amount of geometry when imported into Blender. Some of them have so much that they make Blender nearly unusable. This is strange as they render fine and snappy in Sketchup. The way I import the models is by downloading the sketchup file, then saving as a collada file, and then importing that. Here is an example of a model that ends up having more than 1.5 million vertices and slows down Blender a lot when viewed in Solid mode (in wireframe it performs much better). Is there any way to improve performance or alter the model in some way as to make perform better?

You can make it shown as a Box in the Viewport.
Properties->Object->Display->Choose “Bounds” as Type.

Kind regards

That’s because of the way it’s imported. I would suggest use Meshlab first and export .obj file to use for blender. Even then Remove doubles deals with hundreds of thousands of vertices.

Thanks for the tip eppo. I’ve never used Meshlab before, but what I did was simply import the collada in Meshlab and export as obj for Blender, then removed vertext doubles. It improved a lot but there are now quite a few things imported incorrectly, like the missing windows. Are there any other actions I can take in Meshlab?

That’s strange, if I enable smooth shading I get extremely weird shadows. They are reduced a bit if I convert the triangles to quads, but still ruining the model. Any idea if I can fix this? Or maybe there just isn’t a good way to use Sketchup models in Blender.

Usually weird shadows in smooth shading occurs at location where you have inverted normals.
When you remove doubles, you usually have to recalculate the normals (select all in Edit Mode press CTRL+N or click the Recalculate button on the toolshelf.

Now if recalculating the normals does not fix the wierd shadows it is probably because you have then :
-internal faces
example :

-non manifold geometry
example :

Internal faces and non manifold geometry will always puzzle the normal calculation, resulting in several part of your model having inverted normals , and so odd shadows.

There is an OBJ-Exportscript. With the help of this script you can also turn Normals to the right direction.

Sorry I was wrong. Only the Exportscript in Sketchup for Octane has some additional functions to turn Normals into the right direction. This Exportscript creates an “good” OBJ-File actually.
It’s the same Author for both Scripts.

Edit 2:
Just tried it with your model.

You have to smooth the geometry manually an remove doubles and convert Tris to Quads and there are still some smoothing-mistakes… seems like a annoying task…:confused:

Kind regards

Thanks for the explanation Sanctuary, sorry I didn’t respond earlier. Recalculating normals helped a bit but still didn’t fix it. Indeed there were still internal faces and wrong geometry. Thanks Alain, that works much better, though still not completely. I think I’ll just try to model it myself.