Imported video's audio is not sequenced with visual


I’ve run into a problem trying to use Bender as a video editing solution. The source files I was given were a .MOD file format, one I haven’t used before, and one that Blender can’t import. I couldn’t find any way of converting them, so I simply renamed the file extension to .avi, which worked. I don’ know if that’s perhaps what has brought up next problem.

When import these .avis into Blender’s VSE, the audio doesn’t match up with the video, both in the timeline and when I play it. I’ve gone to great lengths to ensure that the frame rate of the video I’m working with is exactly 25 frames per second, and have set it to render animation with that in Blender. Yet when I render it out, the audio is still out. Not to mention I can’t figure out how to render good quality audio out of Blender. I’ve tried many codec combinations and such, and it always sounds horrible; that is if it actually renders, which for half the codecs it won’t. But that’s an aside problem, though I’d still appreciate some help on that.

The main problem is still that the audio is out of sync with Blender. Is there any way I can fix this, perhaps by solving my .MOD conversion method if that is perhaps the problem, or somehow squashing the video clip to fit the length of the audio, or strength the audio to fit the video?


#1 changing the file extension will not make any difference in terms of the actual container format. Ideally one should transcode the video to a format/codec combo that is supported by Blender.
#2. regarding the audio-video sync, if the length of the audio strip matches that of the video strip in the sequencer when you import the video file, make sure that the sync mode is set to AV Sync (a pop-up menu in the timeline window). That should solve the problem. If the strips don’t match length-wise then there is not possible to achieve synchronization unless you transcode the initial video to the desired frame rate (e.g. if the original video is 30 fps and the desired project settings are 25 fps then the video should be transcoded to 25 fps) before importing in the sequencer.

AFAIK .MODs are just mpeg2 and changing the file extension to .mpg should do the job. Transcoding shouldn’t be necessary, remuxing maybe.

Are you sure fps is 25? A tool like Mediainfo or GSpot is useful for establishing that.

As blendercomp suggests make sure AV Sync is on.

You could try downloading ffmpeg binaries from here: and use ffplay to try playing the files and that will give you console info on the file too and possibility to remux.

And you should be able to transcode .mpg easily (instead of .mod file).