Importing image as planes alters color on bottom material in cycles

when i import images as planes with an transparent background, the transparent planes leaves kind of shadow on the material below. how can i get rid of this?

this is happening only in cycles, viewport shading: rendered and happening only to planes pointing upwards to light source.

This may be based on the premutlipled transparency issue or solved with the better-mix-with-transparency-shader trick.


thanks for your answer but i lack a important information. what exactly is the mix-with-transparency shader trick?

Hi @Timo_Schofer

This is the transparency trick @Okidoki was refering too.

Hope that helps


Just wanted to add while @AlphaChannel & @Okidoki answered. you might need to add a color ramp to the image as plane transparency ( gives finer Control ) and also sometimes better to turn off the back facing or cull the back faces… in the alpha blending under Viewport display in your shader editor tab…


thank you everybody for the help. i will try later and hope that resolves my problem. thank you!

unfortunately the only thing that is happening is that the letters vanished. i can turn black to white or white to black it does not make a difference. also the shading issue is still there.

from the photos from that u guys have posted i got the impression that a colored background is made transparent. my image on the other hand has a colored text and the rest is already transparent

these are my original nodes

i have taken now another picture without alpha value and setup the nodes like u guys told me. but the result is the same like before. the background becomes darker.

Try disable “Shadow”, this would avoid shadows of the letters too.

But i guess your png-format or the alpha channel (not comlete transparent) are somehow messed up or incompatible. Try save the .png in another program like gimp maybe.

i finally found the reason. it seems not the image but the material below that is the problem. it uses and ambient occlusion node and that creates the dark background when the images is close to its surface

1 Like

checking “only local” in the ambient occlusion node is fixing the problem