Importing models

I’m a complete begginer at using this program, so forgive me if I’m making an obvious mistake. I’m trying to import a model from google sketchup to blender, but every time I try it only imports part of the object. Can anyone help me figure out why?

I think the collada (.dae) export from Sketchup is a little wonky. Either that or the Blender Collada import is a little wonky, but I’d be willing to bet it’s on the Sketchup side. OBJ export from Sketchup seems to work ok. It may depend on the object being exported also (SU may have some proprietary feature that doesn’t export well).

Ok, so I took your advice and exported it from sketchup as an obj instead of collada (dea or whatever it is) and its almost working, I can import it to blender and the whole thing shows up, but when I export it from blender to another program its like…way to big, lol. Thanks for the advice though safetyman, I don’t usually mess around with this kinda stuff but I really found an interest in it, might actually start using it more often, get to learn it.

I recall the collada files from Sketchup were giving me a headache until I imported those first in Photoshop, and then exported back to a collada file by Photoshop - that worked for me at the time.

As an alternative, try Accutrans: import the object, and then export as either collada, obj or lightwave. Import that in Blender.

Yes, I can confirm this:

  1. export collada file from Sketchup
  2. import collada file into Accutrans
    2 a) various sketchup objects often have issues with normal alignment. To fix these: orbit view to preferred viewing angle, click the “align normals” button, and any inverted faces show up red toward the viewer. Click these to fix. Click “preset all” to fix most issues, then correct the remaining red areas to fix.
  3. export lightwave object from Accutrand
  4. import lwo into Blender

This way the scale, colours, etc. are all kept intact. Blender’s collada import does have issues with SU’s collada files.


Problem solved guys, thanks for all the advice. I didn’t realize that the third program I’m using had a scale option, lol.

In my own defense, the program I was trying to import the object to just recently incorporated the scale option.