Importing .obj and .mtl from FaceShop 8 (Doesn't work)

I exported a 3d face from FaceShop 8. (Created from a single photo.) It created an .obj and an .mtl file.
I tried importing this into Blender (v. 2.73a). File -> Import -> Wavefront (.obj)
When I do this nothing changes on the screen. (Same as at startup.) There are no messages. When I press “z” the cube becomes transparent. Blender has it’s default installation settings.
I watched a youtube video of someone making a face in FaceGen (different software) and importing it into Blender. When they selected the file, they got a screen with additional import options, which I didn’t get. They are using an older version of Blender, as the startup screen is different.
There are no youtube or Google matches for using Blender with FaceShop.
The .obj, .mtl, and .bmp files are in the same directory.

Here is the .mtl file: (face-a.mtl)


e-mail: [email protected]

newmtl faceshop
Ka 1.0 1.0 1.0
Kd 1.0 1.0 1.0
Ks 0.0 0.0 0.0
d 1.0
illum 2

map_Kd face-a.bmp
map_Ka face-a.bmp

Here is the start of the .obj file (2.1 MB): (face-a.obj)

http: 8.00 19276 36236 19623 512 2 2

mtllib face-a.mtl
v 0.00184919 0.655011 0.00182823
v 0.00200695 0.650896 0.00169871
v 0.00035996 0.650878 0.00158636
v 0.00340845 0.654481 0.00211313

Please supply a demo .obj file so people can test and a .blend file after you have tried to import the obj

After you imported the obj does it show in the outliner as a new object. If it does maybe its very very small or very very large in the viewport and you cannot see it.

When they selected the file, they got a screen with additional import options, which I didn’t get
After you have selected the obj and pressed the Import.obj button there are no further options, they are all there on the file selection window

I get a message that a .obj file is not a valid extension to attach to a message here. How is that done?

I see no outliner of a new object. When I select an input file, the only option is the type of input file.

How do I attach an .obj file to a message here?

Here are all the files
(Save-as from Blender after import)
(Export from FaceShop)
(Export from FaceShop)
(Export from FaceShop)
(Original image - imported to FaceShop)

Opening the blend file you can see your imported objects in the outliner window. They are very very small and inside the default cube. Delete the cube and scale up the objects (shortcut S)

Okay. When I delete the cube, that tiny patch of tan goes with it. I can’t find any controls to make it big enough to see it. I just wanted to play around with this to see if it would do what I need, but it appears that this program has a learning curve that’s through the ceiling. I have seen the beautiful output you can get from it. – I wanted to get the face on the screen where I could rotate it different ways, and see if I could incorporate features from different faces onto the same object (face) - a cheek from one photo, the eyes from another. I’m trying to construct a face from several different photos of different people that have similar features to someone. I have came across these photos with similar features over the years and have saved them. I can’t learn to draw with pencil and charcoal (I’ve tried to learn for years), so I’m trying the digital route now. The person I’m trying to draw was someone I was in love with many years ago (as a teenager), and I don’t have a name or contact information, for complicated reasons.

See attached file


face.blend (1.25 MB)

Okay, I deleted the cube before importing the .obj. Now how to I expand that tiny dot into the 3d face?

Select all the 3 objects in the outliner window or in the 3d view (Shift+RMB to select or A to select all)
Press S to scale, move mouse

Note that the texture is not applied until you add the texture to each material. Use the file I attached above

For more info go to the ‘Getting Started in Blender’ link at the top of the forum

Thanks for the .blend file.