Importing OBJ / DAE /LWO weirdness

Hi gang!
I am converting a bunch of my old LW projects/objects over to Blender, and also have a legacy library of objects in .DAE and .OBJ formats. They all import well, but 99% of the time I have to clean up some extraneous polys (always tri’s, never quads) that seem to be added on during the conversion process. I have this same issue with Sketchup stuff dumped to .DAE then into Blender.
This usually appears sort of like a skin of weird polys that are invisible til I turn on shadows and then you get the look seen in the attached picture. These new polys never cover the whole object, just some of it. Some objects it’s only 10 polys, some it’s hundreds. I then just manually select and remove them and then my object is okey-dokey and ready to go.

Any suggestions to remove these(or never get them) in some automatic - non-maxi-tedius fashion?


Hi, the first thing after importing is Alt+J (Tris to Quads) and than Strg+V > Remove Doubles.
All in Edit Mode with all vertices marked.

Cheers, mib.