Importing .obj from Cryengine. how to find it?

Importing .obj from Cryengine for some reason places them somewhere in space, what key to i hit to go to it instead of spending an hour trying to find it.


Select the object in the outliner and press numpad. or View / Align View / View Selected to focus the view on the selected object (RMB on option to change its shortcut if you don’t have a numpad)

Thanks for that :slight_smile:

I have had times where the imported obj is too big ( the xyz are in meters for something that is hundreds of KM’s across )
if the mesh it too big it can not be displayed and is nowhere to be seen

if that is a problem then just scale XYZ by 0.01 or 0.01

I find the “Blender Units” scale to be a bit of a pain, if you forget to set to Metric (for very damned project) when it comes to exporting the thing ends up the size of a small moon.
Same for importing, it seems to take the measurement and convert them to those meaningless Blender Units and it ends up massive.

If your working with decimals why not just have it in meters, its the same thing as having units that decimal and with meters at least you know what size something is, actually why in 3D creation do Blender think its a good idea to have a measurement scale that means literally nothing, its not just useless its actually something of a pain in the ####.

This needs fixing.

This has nothing to do with using Blender or metric or imperial units.
The OBJ file format has no concept of “units” at all, it doesn’t store if its content is in mm, m, inch, kallicams or whatever. The OBJ file just uses “numbers” to describe an object’s size.

Say, in Blender a sphere has a diameter of 3 m: Blender will export it to OBJ with a size of just “3”. If the importing software uses e. g. millimetres as base unit, the imported sphere will now be 3 mm in diameter after import, because the target application has no clue what unit system that “3” is referring to and therefore just uses its own… That’s why most 3D apps allow to specify at least a scaling factor on export and or import to OBJ - to compensate for differing unit systems between source and target software.

If you prefer to work in metric units, you could switch to metric and save that as new startup file, thereby eliminating the need to explicitly select metric units with every new file. Just saying…

Look in the .obj import settings - clamp scale setting