Importing SketchUp Model in Blender: Problem with Smoothing

I have created a model in Sketchup and I have exported it in both .3ds and .dae.
I have no problem in importing it in Blender (both the .dae and the .3ds verisons of the model) but the smoothed surfaces that where present in the original sketchUp model loose the “smoothness” (they are polygon like).
Surprisingly that problem can’t be solved applying the smooth or subwarf modifiers in Blender, as those appear not to have effect.
Do you have any suggestion?
Thanks for reply

Try this: In edit mode select the relevant faces, and type W->set smooth (Or click on “set smooth” in Editing->links and materials.
Can you post the (relevant bit of) the file here - if this doesn’t work?

It doesn’t seem to work!
I attach the model (this is a very stupid model, two satellites and a dart, but I can’t smoot any curved surface of them).

I’m interested in solving this issue in order to see if it is convenient to keep on modelling in this way… thanks.

I couldn’t attach the file the previous post, as the file was too big to be uploades, I have created a new one, it is just a cone, with the same problem (cone has been generated in sketchUp,. exported as a .3ds file, imported in blender. Subwarf and smooth does not seem to apply.


cone.blend (191 KB)

you are aware blender triangulates the meshes on import? so you have to convert to quads.

No, I wasn’t aware, I’ll study the topic, thanks.

Hi, 3ds is probably the last option for export from sketchup. I’d suggest DAE or OBJ (DAE is done by exporting as Google Earth, kmz, renaming to ZIP; then importing the DAE file via Collada 1.4 import. Or using the new, improved, importer of 2.50). I personally prefer DAE.

Here’s the same file (recreated) and imported through DAE import. the only change done was to remove faces at bottom, and, in Edit Mode, W->remove doubles, followed by W->shade smooth.

Seems okay to me, excepting that there’s a sharp edge which I don’t understand. And Bryce, the sketchup guy, has lost an arm. Poor guy :wink:

(You can delete unnecessary parts from your file to reduce size. If that doesn’t work, you can upload it to Rapidshare or Mediafire, and post the link here.Just a suggestion. )

Good luck.

Edit: Actually I used sketchup 7.1’s new DAE export, to export directly. Perhaps if I’d done it the old way, Bryce wouldn’t have lost his arm :wink:


cone-dae.blend (287 KB)

Oh okay, well its very simple to fix,go into EDIT mode- A to select all faces - Mesh - Faces - convert triangles to quads. or Alt - J

then I think F - auto can also clean thing up a bit.

problem with sketch up models is the way they are modelled is different from any other 3d aplication. so you get unusual topology.


Makr, thanks for the file, effectively you could solve the problem with the cone, I have attempted to do the same with another file (attached, it is a darth), but the W menu, remove doubles, doesn’t remove anything (o doubles removed) and I don’t have the item “shaded smooth”.
I have exported the .dae in the old way, but it doesn’t make any difference.
Still seems impossible to smooth it.

MrJynx, I have tried the conversion of triangles into quads. The conversion works, but still remain the problem of the impossibility to smooth (the darth goes a little bit weird smoothing or subsurfing it).

In another file it happened that by smoothing the object become subdiveded in many different surfaces…

I guess you are right, that SketchUp generates some strange objects that can’t be manipulated correctly. I will obviously start modelling directly in Blender (I thought I would have saved time using sketchUp but lazy shortcuts never works!).

Thank so much for you time… in any case I have learnt few things thanks to your advices.


Dart.blend (743 KB)

Here’s you are (Still needs some work)

For some reason ‘CTL+A->apply scale’ made the object huge. So the following - maybe unnecessary steps: ALT+P->Clear and keep Transf (?); followed by ALT+P->Clear Parent Inverse. Then CTL+A->Apply Scale.

Main work: In edit mode, select all faces and press W->Shade Smooth.

And, yes, I agree that it would be better to do only the basic, rough forms in Sketchup - using it as a sort of semi-CAD program - and do all your actual modelling in Blender. Example: the cone: Import circle; extrude; select top vertices and scale to 0; Remove doubles (W->Remove doubles)

Good luck

Wait a minute! Back up!
How did you get a model to import from in DAE or 3ds? I have yet to find anything that will import. I’m running blender 2.49b, and python 2.6.2.

How’d you do it?

File/Import/collada 1.4 dae
Or, from a python window, Import…
Any file with faces should export from Sketchup.

It took me awhile to figure this out. Here’s what I do now:

  1. Explode any components and then turn them into groups (I’ve never gotten a component to export in a .dae file and show up in Blender)

  2. Once imported, clear the parenting relationship on all the meshes. If you have a scene with lots of pieces, then you’ll have parenting lines drawn to the center of the scene from each mesh

  3. Scale the imported meshes down to something reasonable. I tend to used 1 blender unit = 1 meter (which works out nicely to export to Unity)

Once I figured that out, I’ve been able to export very well from SketchUp 7.1 to Blender using dae files.

>>Scale the imported meshes down to something reasonable. I tend to used 1 blender unit = 1 meter (which works out nicely to export to Unity)<<

Good advice :slight_smile: That’s, I think, the scale which renderers like LuxRender and Yafaray also use.

I’m not sure about exploding the components. AFAIK components import fine - as Linked objects -which you can always make single User (U key).

I did some more testing and got mixed results. It seems that if the flag “Perserve Component Hiearchies” is checked on (which is is by default) in the options for exporting a dae file from SketchUp, then I don’t get components showing up in Blender. If it’s checked off, then components show up on import.

Hi. Can you post the Sketchup file here? I’d like to try my hand at it.

Why not try the KML (Google Earth) export, instead? I’m using the Sketchup free version, which, afaik, doesn’t have any options for exporting KML. I exported a quite large test project, without many problems. Perhaps, excepting for groups (Or was it components in groups?).


I have noticed that if I export the file as .dae from sketchUp then in blender I can smooth the surfaces while if I export it as .3ds blender doesn’t allow me to smooth the surfaces. Nevertheless the rendering of the “current view” appears to be sharper if the model has been imported as 3ds than in .dae (of course, same settings). Mysteries…

Using an edgesplit modifier will help a LOT. You can mark where you want it to be sharp yourself (with an edge or edges selected, press CTRL+E or open the ‘edges’ menu from the ‘mesh’ menu) or set a maximum angle. the maximum angle should actually work pretty well for this, since you’re working with a fairly clean, mechanical model, and not something like a game model, where sharp edges are more about art and effect. I’d set the maximum angle to be about 50-60 for this model.

Yes. But what about the Garage Door??