Impossible to eliminate fireflies Cycles 2.79

I’ve been struggling with cycles, I always have fireflies in 4k and even going as far as 5000 samples, I’m using an HDRI and the denoiser won’t help. I have been searching the whole web by now, I’m looking for answers so I would appreciate some help.

Multiple importance is ON but dont help. Clamp options dont do the work properly.

Thanks in advance!


  • Disable caustics if you haven’t already (unless you absolutely need them).
  • Use clamping
  • do manual denoising if there still are fireflies using cloning and/or luminance masking or whatever it’s called

(image averaging and downsampling might help too)

First of all, thanks for responding.

Disabling caustics didnt fix nothing on my scene.
Clamping completely destroys my scene blurring my front and back car lights. ( I tried diferent Clamping options I saw on internet).

I don’t think that manual denoising it’s a good option, because there is A LOT of fireflies.
The fireflies start appearing at sample 10 more or less… And I need almost 2000 samples to get enough resolution…

There is another way?

Thanks.

I recommend you just use the denoiser if you really don’t want to use secondary bounce clamping. You can limit the denoiser effect to certain passes, these fireflies are likely coming from your indirect glossy pass, so only enable the denoiser for that and you should be good.

Okey, I will try this solution later today.

But I have to put a big amount of radius on the denoiser or keep it at default.

I tried to apply denoiser to the whole image and didn’t do nothing. But I didn’t use it only on the indirect glossy.

I will try it

Thanks

hi… sorry to ask you again…

  • but do you really got such a mass on fireflys by 5000 samples?
  • do you’ve let this picture render… or do you have the firefliies in the preview?
  • do you have multible Importance (world setup / Settings on?)
  • do you use composer?

what settings do you’ve set at Light Paths?
i usually those settings… and have … less… less fireflies…
grafik

if that doesn’t fix your problem… maybe you should check, if the problem cames from the material shader you’re using…
the rearlight… looks a bit of to much bright / contrast.

btw… check out my thread… all of the pictures are made with those settings and 256 - 512 samples… even just one is at 6000smp. my space movie project

The denoiser only operates after all neighboring tiles have been rendered so won’t affect viewport renders at all, until the viewport preview gets support for denoising. The denoiser should be quite obvious at low samples and should change very little at such a high sample count, apart from removing the fireflies.

Yes, whatever samples I put it gets fireflies
When i render it gets the same result as the preview.
Multiple importance is ON yes.
I dont use the composer on blender, i want to extract the render for photoshop.

The shaders are simply Principled BSDF

My scene is configured with this.

Thanks for your time.

Yes, I used denoiser on the finished render and it didn’t solve the problem. The wihite dots are much bigger than 1 pixel so the denoiser dont delete it.

If they become large spots in the final render, you will need to use indirect light clamping. It really shouldn’t impact the brightness of your scene by very much.

You can go as far as 2.00 on the clamp indirect and 10.00 on clamp direct and you will probably not see any difference on your image except less fireflies. On top of that, set filter glossy to at least 1. With these in place, you can re-enable reflective and refractive caustics.

IMHO it’s really poor decision those caustics switches are there, especially now that we have clamping. They are the first thing users touch, thinking it will help them, but most of the time it will just ruin accuracy of their scenes with not much in return.

1 Like

@smilebags Do you have some bot to automatically like any of my replies as soon as I hit enter? :open_mouth:

I forgot about Filter Glossy, since I just leave it on all the time unless I notice something off with the caustics. It solves 90% of cases.

Haha no, I just have the page open and noticed you commented. Filter Glossy was the missing part of this puzzle in my mind.

Ah, it was uncanny fast :slight_smile:

Sorry if I scared you :wink:

1 Like

hi… do me a favour and try the settings i’ve send you with 2000 samples… can you do a 1080p render with it… ?
btw… do you use CPU or GPU render? if GPU which one?

Hi!
I’m using GPU -> GTX 1070. Never had this problems on blender…

I rendered the image as you told me and the result is this.

Denoiser is activated and solved the majority of the fireflies but theres quite a lot more that they are still visible. Without denoiser its totally a mess…

I tested with your clamp configuration but it didnt work aswell…
and i lost some quality on the rear lights too…
i post the resoult here…
I dont know what more to do.

Thanks for your help guys!

hm… first at all… that isn’t a 1080p shot…
good thing i’ve a 1070 too… and i don’t have such problems. okay… do yourself a favour … because i guess, that there is something with your settings. can you open a new blender file, switch to cycles, set your gpu as render and and append the 3D model of the car… you said, you use a HDRi for background, just inser this one… just with the blender default settings. on Render Presets, just push it to 100% and set to 1024 samples… in performance, use 256 tiles. try again that render. nothing else please, do again a render…
else… i’ve a question… do you just have the problem with this model? or do you have the same problems on blenders classroom bench?

Its a 1080p render, but i used screen cut to paste it here,
yes, its just that model, i modeled an interior time ago and didnt got this problems…

I will create a new blender file and apend it, and show the results…

Thanks!