Impossible to eliminate fireflies Cycles 2.79

I got this result in the new blend file. Which is not good

You did not lost that much of quality. I mean it’s not like few less bright highlights will change how realistic your work looks. With the setting changes, you have managed to reduce fireflies to just noise. Now you will just have to increase pass limit and wait a bit :slight_smile:

I will render with the clamp options activated with 5k samples and post the result here…

But yes, i lost a lot of quality… Compare for example rear lights

WITH CLAMP

WITHOUT CLAMP
(fireflies rebelion btw)

hmm… sorry … but the only idea i still have aren’t based on the cycles or settings… it’s more, that you’ve problems with the shader. maybe the rearlight shader and the shader u’re using for the glass made some problem… just as idea.to have a focus on it.

do you have the same problem with CPU renders too.? just to make sure, that theres not a CUDA / NV Driver problem.

btw… do you’ve checked the classroom or bmw27 bench… if there is also such a fireflies mess?

Then you may want to just increase clamp, to like 10 or something. Cycles’ clamping implementation isn’t perfect, but it will still help a lot.

I’ill try iwhen I come back from work.
CPU renders make the same result.

Thanks for your help guys

Okey guys, good news. The problem in the front was solved with Clamp. It seems that was caused by the HDRI, because with other HDRI the fireflies are inperceptible.

The problem in the back lights was caused because the emissiv
e was too strong.

I let the results here. Thanks for your help guys!


3 Likes

I guess the lesson here is to look for the root cause of the fireflies before trying to clamp and denoise them away. I personally try to avoid any destructive process on my renders at all costs (rare situations permitting). :slight_smile:

Aside from the occasional situation where rays bounce around until they pool in one spot, fireflies can often be completely eliminated before resorting to clamping and denoising. 9 times out of 10, fireflies are caused by lights and/or colors/values being too bright. It’s always a good idea to keep in the back of your mind that mid gray is RGB 0.18 (LDR/relatively speaking). Calibrate your light values and scene exposure accordingly. Proper values are often MUCH lower than would seem. On that note, it’s also good to double check your materials to make sure you don’t have anything funky that is breaking light conservation. TOO many bounces is another issue. Sometimes 2 or even 1 is enough to get the job done while minimizing the chance of ray pooling.

In the future, I’d also recommend taking a look here:
It’s an often forgotten setting, but can have a massive impact on fireflies and grainy noise.
samples

Just some additional food for thought. :smiley:

1 Like