Improving rendering times? How to?

I’m rendering a cylinder which rotates, surrounded by rotating extruded text, surrounded by video windows that rotate. Pretty standard 3d stuff. The render times are extremely long – on a dual core with 4 mb ram, 32 bit Windows, about 2 frames per hour at NTSC resolution with the interal renderer. No radiosity, but there is some ray tracing going on.

I’d expect it to be better on my Quad Core with 8MB 64 bit system at home, but its about the same. Any ideas how I might improve this performance?

Make sure you’re using all your cores. Try changing the Xparts and Yparts to see if that helps in any way.

You may be able to share the rendering between both your machines.

Richard

I’m using all the cores. The x parts and y parts are also set to 4.
I think it has something to do with the 3d extruded text. Lots of polygons there. But its still extremely simple compared to a landscape or a frame for a game. I can see why you need a render farm in this biz!

I believe all your meshes have a low vert count. Maybe you want to double check that. As for the raytracing, what exactly are you doing with raytracing? Mirror, transparency, just shadows? But really, it would be nice to see the .blend file so we can see what’s going on.

Here’s a 3 frame sample you can look at

I’m averaging around 3 frames/hour on a dual core Win XP with 4 GB. Strangely enough, its even worse on my Quad Core, 64 bit, 8GB ram at home. About 1 - 2 frames per hour.

It looks like you’re using blurry reflections. That is going to make your render times skyrocket. But maybe you aren’t. Are you? Can you post the blend file so I can look at. Your scene looks really simple, and you could probably get the render time to under 10 seconds on your dual core.

I do have motion blur on. I uploaded the .blend file to media fire:

It would be great if you could look at it.
By the way, this is for standard video broadcast. That’s why its 720x480, 100% quality, etc. If you don’t start here, by the time it gets on the TV screen, it looks pretty fuzzy.

Try upping the octree resolution. Try 256 and 512 and see if any one gives you better render time.

Do you have a very large plane in your scene? Like a very large ground plane or a very large backdrop plane. If it is the case, then it is most probably what is causing your slow render times. If you are using such very large plane, try reducing it to the minimum you can that fits in your render frame.

http://wiki.blender.org/index.php/Doc:Manual/Render/Performances

thanks for this link. Good stuff to know.!

No large plane. Not sure about the octree resolution. I’ll have to look for it. Where do I find it?

The problem is probably the poly count. If I read it right you have just short of 10 million vertices. For a relatively simple scene that is quite a lot.

Reduce the subsurf level on the central cylinder and reduce the vert count for the text. You could try the poly reducer script, but it will probably be quicker to redo the text. When converting a text object to mesh reduce the DefResolU setting on the Curve and Surface panel to keep the poly count low. It should render a good deal faster once you reduce the number of vertices.

I’m pretty far into the render at this point. If I reduce the vertices on the text as you recommend, won’t that change the look of things quite a bit? Jeez, if I had to redo it, I’d have to star the render all over again. It would be pretty much impossible to match it back up perfectly…

It may not change it much. I made a quick example, though probably with the wrong font.
It reduces the vertex count to around 50k

Have a look and see what you think:-
http://www.filefactory.com/file/ah2ee31/n/ASAF-RenderBGFirstPart_7z

The octree is where you see the number “128” in the render panel. You have a lot of small faces and they are located in small portion of the scene space. Increasing the octree resolution should help a little.

Okay, I downloaded your blend and it renders in 1 min 17 sec on my dual core. I turned off the glossy reflections, put down some of the subsurf levels that were unnecessary, and did some vector blur in the node editor instead of regular motion blur and got it down to 36 sec. Both renders look, like, exactly the same. I’m not seeing 2 frames per hour. But, I didn’t have any of the textures for your scene. And seeing as it renders in a minute without them, I think your textures may be the problem. Oh, and I couldn’t get the antialiasing to work either. You had it at OSA 16, but it was had really hard edges. I ended up just using full oversampling. But, looking at your scene, I think you’re making it way too complicated for such a simple scene. You could probably make it render a frame in less than 10 seconds and make it look way better without all that glossy reflections and transparency and stuff. Good stuff doesn’t always have to have tons of lights and use raytracing for everything. I would make an example file to show how you could make it better without all the fancy features, but I don’t really want to steal your thunder or anything. Just here for help. Maybe you could post the blend with all the textures and things and I can see if that makes a difference.

Please steal my thunder, I’m not proud!

It sounds mainly like settings changes, and not a big “do over” on the modeling.
Instead of me trying to decipher your hints, could you just send me back the blend file you downloaded, with your new settings? If you’ve improved it as much as you say, it would be faster for me to re-render the whole thing.

Okay. I actually didn’t finish all the changes. I was going to go see Up at 4:00 (my timezone). So, that means, I’ll post it hopefully within the next hour and if not, by 9:00pm. My time…

Okay, I got completely lost looking through your blend file, especially since there were no textures included. You’re probably ten times better at blender though, because half the time, I didn’t know what the stuff you were using did. So it was easier just to redo the whole thing. I tried to keep the basic scene the same, and jazz it up a little. Well, I didn’t have any textures, so you might want to add those too. Anyways:

-Background torus stuff has not been animated yet. Just add some random rotation. It’ll always render behind the pillar thingy, so don’t worry about it getting in the way.
-Textures, as I said before, need to be added.
-Should render in a minute or less on your machine.
-Camera movements aren’t animated, just import your curve path from your original file.
-The video screen things have a trackto constraint, so if you want it like it was originally, just take that off.

I don’t know about the green color scheme though. Not very sport-like. You might want to change up the materials a bit. And my style of stuff isn’t really sporty in general either, so you might consider toning it down a bit too. Anyways, hope that helps.

Blend File:
http://www.nyrix.org/resources/azmisov_asaf.blend

Attachments


Wow, that’s a beautiful thing! I may use this for next time. This client likes to see something new every few months. With all the transparencies and radiosity, how long does this take to render on your system? Looks like it would be pretty intense.

Status on my project: After trying all of the various advice(s) I’ve received in this thread, I’ve been able to considerably improve the render time. I did away with ray tracing and turned down the OSA to 5, and turned off the blur. It renders at around 30 sec/frame on a dual core, and between 9 and 20 seconds on my home quad core. So this is manageable.

I really appreciate everyone’s help. Its been a real education.

I’ll post the final when its done so you guys can see what you were helping me with and give yourselves a pat on the back.