In need of lighting advice


(Cotaks) #1

Hello,

I’m stuck with some lighting problems (screenshots)

In the screenshots i highlighted some issues that i have, and i wonder how to fix that without using other lamps, or baking the textures. I want the scene to be like in real life, just with the usage of normal lamps.

So the problems i have are:

screenshot 1:

  • the column why is it not lit at the base?

screenshot 2:

  • why is the side of the wall black? and not lit up like the wall in the back is?

Both:

  • why is the roof always so dark?
    i know lights should shine down, but in blender it shines in al directions. (floor/roof are same texture)

Anyone got some info/pointers/or anything helpful to solve my issues?

screenshot 1:


screenshot 2:


I could use hemis to lit the whole scene up a bit, but this also causes other problems, so i want to avoid anything else then the normal point lamps in this case.

Thank you.
Cotaks


(JustinBarrett) #2

I think with the pillar the lights are too close(too close to the pillar itself), remember that point lights are just a vector…there is no surrounding mass to better distribute the energy…same goes for the dark areas on the ceiling etc.

also the spec level might be a bit high on the walls…

to get better point lighting try using a much larger fall off with a much lower energy level…I generally use only sun or spot…so I amy not have the best advise…

I don’t know if that will help…but until someone has a better lighting philosophy maybe you can play with that.


(sdfgeoff) #3

The “missing factor” is … bounce lights.

In the real world, light bounces off surface. After all, that’s how you see. This light also illuminates other things. So if you have a light in the ceiling, the light hits the floor, bounces back up, and illuminates the roof. Unfortunately doing this in a computer game is computationally expensive. Have a look into real time GI systems.
The other solution is to place bounce lights. Generally these are “opposite” where the light is coming from. If you’re after an example, have a look at the lighting setup in this blend. Something similar was used in this video too.

A good tutorial to watch is this timelapse:

There is a tutorial as well, but it’s in German:


(Nick Manchul) #4

Hi.

  1. The column is not illuminated in the basis, because the light source there does not reach. It is also visible from the top - there is also a dark place, but due to the side lamps is less dark.

  2. The wall is dark, because there is one light source with a small distance, and in the place with a column of them two, and they amplify each other.

For illumination of a ceiling, one more general lamp of Hemi is necessary - 0.2 - 0.15, in the upward direction. In BGE without shaders, the light is not reflected. …and if the materials are the same (with the same settings), then there is also a large role in the viewing angle of the normalmaps - so the material may look different.

Good luck …

p.s. I’m not a Pro, and I can be wrong.


(Daedalus_MDW) #5

im very careful with lights, only using points when absolutely necessary. i use two hemi for basic fill light, point lights for occasional accents, and a sun if needed.

the bge is only forward rendered, which means most gpu will choke on 7 or 8 lights. i have a gtx 970 and still find myself running out of lights.

use negative lights to darken some corners if you need. absolute blackout areas in games is very unattractive, even if its not realistic. like in film, you almost never see a pitch black scene (unless theres glowing eyes).

you just need to be mildy convincing. fresnel sim is another good way to boost light variance. remember to give the reflection some emission or shadeless.


(Cotaks) #6

Solution for the column on the bottom.

I think with the pillar the lights are too close(too close to the pillar itself), remember that point lights are just a vector…there is no surrounding mass to better distribute the energy…same goes for the dark areas on the ceiling etc.

That’s not it, lights are far enough away,for the ceiling well it uses the lights falloff, easy to solve with a hemi.

The “missing factor” is … bounce lights.

True, and for the ceiling it should count, and be solved with a simple hemi,

  1. The column is not illuminated in the basis, because the light source there does not reach. It is also visible from the top - there is also a dark place, but due to the side lamps is less dark.

light does reach there thats the problem, the light is 1 meter away from the colomn it’s shines right in the face, so being blacked out is not a good thing. And ask yourself this, why is the floor lit up around the column? it should be dark as well.

im very careful with lights, only using points when absolutely necessary. i use two hemi for basic fill light, point lights for occasional accents, and a sun if needed.

the bge is only forward rendered, which means most gpu will choke on 7 or 8 lights. i have a gtx 970 and still find myself running out of lights.

same here, i use max of 5 lamps and move em around, 5+2 hemis in total, if outside a sunlamp as well.
But that is just for low end.

I cant believe that your card has trouble with 8 lamps because my rx470 can handle 100+ with ease(60+fps, screenshot below) so i wonder why you cant while you card should be better then mine.

use negative lights to darken some corners if you need. absolute blackout areas in games is very unattractive, even if its not realistic. like in film, you almost never see a pitch black scene (unless theres glowing eyes).

But that is adding more and more lights to the scene.

For the column it’s another story, and i found the problem.
the problem lies in the Smooth(instead of Flat) shading (T key panel).

I added an up side down and straight up hemi as usual, energy 0.04 both, to lit up the scene a tiny bit so it’s not totally black
I could use the environment light in the world panel, need to see/test if that is a solution.
also all new wall textures, and tuned down specular.

Anyway the biggest issue is the column, here with and without smooth shading



and with 100+ lamps


But the question now is, how can i use smooth shading, and have the right lighting(column)?
can it be done without adding more lamps or baking?


BGE removing lamps to performance?
(sdfgeoff) #7

Use the edge split modifier on the column so that the top/bottom stay “sharp” while the rounded bits are smooth. You used to be able to use the “autosmooth” option in the mesh panel, but that didn’t work in-game last time I tested it.

From left to right: Flat, smooth with edge-split, smooth without edge-split



(Cotaks) #8

Use the edge split modifier on the column so that the top/bottom stay “sharp” while the rounded bits are smooth

That’s it? omg, works great. After using it thought lol, lets just delete the 2 faces, also problem solved. Kinda silly that it works like that.

Thanks!


(JustinBarrett) #9

you can use smooth shading and just add an extrusion through the floor…if you cannot adjust the vertex normals.

What I said about the point lights being too close to the pillar is completely plausible…due to the glancing angle…the ceiling is more perpendicular to the light than the bottom of the pillar…but you seem to have figured it out with the smooth shading vs faceted.


(Cotaks) #10

What I said about the point lights being too close to the pillar is completely plausible

True but not in this case, because you can see the lights arc, i increased it and it stayed the same, and as you can see, you even see it black in the latest screenshot i posted, the one with 100 lamps.

due to the glancing angle…the ceiling is more perpendicular to the light than the bottom of the pillar

That could be but, why is the floor around the pillar lit up? remember i had no hemis in the first 2 screenshots, and just the pillar had the issue.

but you seem to have figured it out with the smooth shading vs faceted

Yes, through luck, i tought to reduce it’s face count, it tuned smooth shading of to see how the faces looked, and at that point the whole lighting of the column changed to how it should be.