In the Object Transform window there is no Dimensions display.

I’m using 2.69 on a Windows 7 PC. With the default cube selected:

In the scene I changed the units to metric.

Looking at the Transform window I see three tables, Location, Rotation, and Scale. Under that is a selection box for Rotation Mod. That’s it, there is no Dimensions table no matter how I scale the Transform window.

Do I need to enable it or something?

Look in the Properties panel (shortcut N)