Incorrect bending after applying Armature Deform With Automated Weights

Greetings!

I am following one of Polygon Runways’ tutorials for character creation. In one part he applies the parent to the whole mesh and to the armature with the Armature Deform with Automated Weights and then he moves the base of the foot and it moves accordingly while bending the knee.

I am following the tutorial with a different design and until this part everything was but when I went and tried bending the knee the same way it ends up going side to side. Is there any way to fix this? I am still unclear on the rigging process and aspects and was hoping to learn from the video.

image

For more angles of what I was doing here they are. I would upload my file but I just did this account to ask for help as I have already invested a lot of time in this project :confused:

I just discovered that the position of the poles was like in the picture and apparently thats what its using as the basis for the odd movement.

image

I don’t really know how to handle the poles. Is it possible to change them without issues? I saw that I could display the vector in pose mode and move it, but this didn’t change its position in the edit mode of the rig.

It doesn’t really matter-- pole targets are made to be moved.

However, if you want to adjust the default way the leg wants to point, find the bone with the IK constraint (easier to see in without bone shapes, in pose mode, because that bone will be yellow), select it, and look on properties/bone constraints. On the IK constraint, there will be an entry for pole angle. Slide that value around until you’re happy.

1 Like

I appreciate your response.

I checked but I don’t seem to have yellow bones. Only green ones. And the bone constraints only have “Copy Transform” in them so I can’t find the Pole Angle option. So I suppose I’ll go and move Vectors and targets so that it suits what I need.

It looks like you’re using Rigify, in which case you have IK bones (yellow bones). You may need to unhide bones or look on other layers.