Incorrect EnvMap, how to fix?

I’ve got a model which has lots of reflections. In fact it’s made nearly entirely out of metal and to give it some edge I put all the involved materials to mirror reflection with values between 0.2 to 0.3 . Now this renders horribly slow so making a rotation view of 400 frames takes ages. Now for such a view a simple CubeMap EnvMap hack would be enough. I tried setting up the material with an additional texture of EnvMap type disabling ray mirroring. In general this works except one big time show stopper: the env map gets relit. I noticed that the render looks crap with the envmap and not anywhere near the same as with ray mirroring. Looking closer I noticed what happened which is what I consider a bug. Blender renders the cube map using the lighting in the scene which is correct. But while applying the envmap to the object it lights the envmap once again which is incorrect and ruins the envmap. I could not find any button to disable this behavior. So the question is:

Can you use a non-lit envmap texture in an otherwise lit material?

Because if not I would have to hack together some heavy node action to fix that problem and that’s really annoying as I have quite some materials ( 14 ) in that model. Making a custom node setup for each would suck.