Increasing the length of an animation

I saw in another (older) thread that you could increase the length of an animation by scaling up the curves in the curve editor, but it doesn’t seem to be working for me.

I have a camera moving on a track and influenced by different objects at different times. When I select all and scale on the x axis, not only do I then have to realign the starting point back to frame zero, but for some reason the influence gets off.

All I really want to do is triple the length of the animation, but I want to add in more frames so that there are triple the frames as well and there is no choppiness.

I’ve played with frames per second as well and that seems to have no effect either. Is there a simple way to do this in blender?

First of all, I would use the Dope sheet rather than the Curve editor, as it allows you to effect all the objects in the scene at once.

Also, when you scale the keyframes, make sure the curser is on the start frame - you see the frames scale around the selected frame in the same way an object scales around it’s object centre.

But also - if you are using Follow Path constraint, the settings for many frames the object takes to get to the end of the path … they are in the properties for the curve in the Path Animation panel.

I use the graph editor to tweak animations. I have never used the dopesheet, but I am making a mental note to use it for a while to see if it helps me do things faster. I have no problem visualizing my animations as curves. You have at least 2 points on any animation. Your first keyframe and the ending keyframe. Same on the curve. Every keyframe you insert between the first and last is effectively subdividing the curve. You can grab any point on that curve and move it left or right to change the location of the keyframe. You dont’ want to scale a whole curve at once usually to make it longer. You would select all but the first keyframe/curve point and move them to the right to lengthen your animation.

If you scale the whole curve at once it will move the last keyframe and the first keyframe away from eachother and it will make the influence curve higher which will result in a more dramatic effect and it will push your animation start into the negatives if you originally started on frame 1. Get it? You probably saw someone scale the whole curve after selecting the “active selection” pivot point. That makes things scale/rotate as if the last object or point you select is the center.

Thanks for the replies. I’ve tried the dope sheet now as well as the graph editor. I constrained my scaling to the x axis so the influence stayed at 1. Two odd things are occurring:

  1. When I playback the animation in the default viewer, it seems to run at exactly the same speed as before.
  2. The Influence, though still at 1 no longer seems to influence the camera like before.

Ok, I think I’ve figured out part of the problem. My camera moves on a path. So even though I scale up everything in the scene, the camera still moves along the path at the exact same speed as before.

How do I control the speed of the path?

use the path animation in the curve data panel. the number of frames is how may frames it takes fir the object to traverse the path so at the default setting it take 100 frames. if you lower the frames then it will travel faster. 50 frames= twice as fast. if you increse the frames then the object will move slower. 200 frames half the speed.

Ok, I am rendering this for work and some other things came up and I had to put it on the back burner for a bit, but I’ve finally figured out what the issue is. Everything scales fine except the particle effects. I’m using a Halo effect on some particles in the animation to make them look like laser beams (more or less) and since those effects are set to go off between a set number of frames that are hard coded, when I rescale the other elements on the timeline, it throws them off.

Unfortunately, I don’t know of a way around this other than going in and manually changing the frame start and end points. Is there a better way of doing this that anyone knows?

Ugh, another problem. Because the particle effect takes place over a longer time, the laser glow is now quite watered down. I tried increasing the number of particles in the emission settings as well as the lifetime, but it keeps resetting the lifetime back down to the original value of 5. What is going on? I’ve freed the Bake and re-rendered it many times, but nothing seems to work…

  • EDIT -

It looks like the lifetime setting was also part of the animation and so to change it, I will have to adjust the curves as well. So the real issue now is simply how do I do this across multiple particles easily and get the intensity of the glow back to what it was before? Changing the halo material doesn’t seem to be working…

Also you might want to click on the first key frame while holding shift after you’ve selected all the keyframes you want to scale then set your pivot to “active selection” I think that is the right one. That makes them all scale away from that point and leaves it alone so your animation doesn’t scale into the negatives.

Just add more particles easy fix. No you can delete the key frames for the particle life time. No need to key frame that anyway unless you want it to sputter. Are you using auto key visual or something? In my experience it is always better to manually set key frames for each thing you wish to animate. I never use auto keying. EVER But I"m no animation pro either, so maybe it has its uses. I just like to have full control at all times. You can always select all the objects and functions you want animated in the graph editor or dope sheet and then invert that selection and press x to delete the other unneeded ones.

Thanks Brent, yes it did scale into the negatives but I just grabbed all the keyframes and shifted them back to start at zero. I’ll use your tip next time, though. That’s good to know.

The problem I’m having now is that adding more particles doesn’t seem to be working, neither does bumping up the Add value of the material or increasing the particle lifetime. In fact, even after freeing the bakes, the particle rendering looks the same every time no matter what I do. Do you have any idea why the particle animations aren’t working?

I’ll post a couple of screenshots so that you can see what I’m talking about.

Current particle render:

Original Render:

As the particles travel down the red path, they eventually grow longer and get “tails” like light streaks. Perhaps the difference in brightness is not terribly noticeable in these still shots, but in the animations it is more pronounced.

Doh! I just realized that I had saved an image strip into the Video Editor. That’s why it was always rendering the same thing. Ok, I think I’ve got it figured out now (finally!).