Incredible Animation issues??

Hi every one, i am now a ex 3DStudio frustrated user, because now i am a 3 month happy Blender User:).

I am working on a project very exciting, making some fantasy things, like angels and so.

After cry for its severals problems and some incredibles bugs never unresolved Now i am reanimating one animation that i made in 3DStudioMax, i now feel amazed with this little but powerfull program.

…But not all was easy, some things was hard to figure out how make.
One of that things is this rare prblem:

I can’t get the animation playback in the viewport run in real time. i mean, the time line has 60 seconds and it is completed in 85 seconds, i check this with my stopwatch.

I almost sure that blender can play the animations in viewport drooping some frames if it is necesary, i investigated everything i have checked Sync button in the anim panel, i play with ALT+A and so and so.

The rigged character is very light to compute, i can manipulated very very easly and when i drag the timeline crusor it drag so so so smoth and fast, but for any reason it CAN’T start form the second 0 and reach the second 60 in 60 real seonds.

In 3d studio Max i use some skining and rigging options very powerfull but very slow, but any way when i click play in the view port the frame rate is slow but it droop frames to respect the timing of the animation.

There would be a manner, i am coder also and if it is a desing problem i’ll try to solve it my self, but obviously being sure about this issue. Any way i’ll get involved soon.

Here is a sample of what i am doing, in the next week i’ll post in the projects section some teaster images!

Q2: Is there a way to group objects in a single Action in action editor? like the bones in an armature.

Thanks very much!

Attachments


Hi,

I might be wrong, but I think you need to use the play button in the timeline panel instead of ALT-A for synchronised playback.

You might want to drop your viewport settings down to bounding box mode just make sure your computer is fast enough to do the playback. Also only have one 3D viewport on your screen at a time if you are attempting realtime playback. You can easily do this by moving your mouse pointer over the 3D window and pressing CTRL-UPARROW. This will cause the current window to become full screen. CTRL-DOWNARROW will restore the interface.

Just an FYI, I never assumed Blender could do realtime playback. The only program I have ever seen that actually tells you it is doing realtime playback is After Effects.

Thanks for you replys!
-I got a phenom 4 cores , GForce 9xxx GT etc, this computer is fast!
-I played in every way ALT+A, play button all!

After fighting a lot of time more, i find out that the character was with collision enabled, and when i turned it off, the speed incresse good enough to play nearly to real time. its extrage bebcause no one physics objects were in the actived layers, later, i put all unecesary objects in other layers and hide them, now i can play the anim in real time. but i insist that it is a design issue or something.

In 3DMax you can have a extremly haevy scene, but it play in real time, even if it is runing at 5 or 4 fps, blender should do that because I can drag the cursor in the time line perfecty well in a somth and fast manner, why this cursor doesn’t run in the real time when i play is a mistery for me.

Well thanks, and any one know if is possible to group action for objects in the same way that bones in the armature?

Thanks!

In the timeline window, Playback->Sync playback to frames per second, and set you fps in the buttons window, scene context.

I Actually leave the screenshot in the first post where i showed that option is on.
Thanks any way!

Agus, I found a workaround for relatively fast review of animation at full speed, though it relies on an external program:

In any 3D window, at the far right of the row of buttons and controls, is a dark gray button that when hovering says “Render this window (Ctrl Click for anim)”. I call this the “playblast” button – it can render your OGL (or whatever) 3D viewport to a sequence of frames that can be easily reviewed in a program like Virtual Dub, at whatever speed you desire. I find it much more accurate than real-time playback in Blender, when evaluating animation moves.

The frames will be written to whatever output folder & filename you’ve specified, so be sure to use a filename that won’t overwrite any fully-rendered frames you may have there – I usually add “PB” for playblast to the output filename so I can identify the sequence easily in a folder.

You can also get 100% sync this way if you have audio in a file that VirtualDub can use (like .wav). It’s not as convenient as having good sync in Blender but it is absolutely accurate.

You can also use Blender’s Sequencer to check motion and audio sync, though there’s often some frame-dropping. Just load the playblast image sequence (or a .avi movie made from the sequence) and the audio in and match them up. The Sequencer’s very good for assembling stuff “as you go” to check overall sync to audio as animation sequences are polished off.

Hi, I use the same trick than chipmasque for playback, I noticed though that the ogl rendered pictures are smaller than the actual camera view, so i zoom in a bit in the 3d view to match the cam’s real view size.

Hi, if you need a free software allowing to play a sequence of image in real time, even for high frame rate, Framanip Pro is now free :

http://www.ranchcomputing.com/M_framanip.php

It can help if you want to see your animation with accurate timing,but only works on sequences of images (so, no sound possible).

Thanks all of you for your replies, but it seems that this is a design issue of blender.
I’ll e-mail to Aligorith who is one of the master coders of blender to see the posibilities of fix this problem.

3Dmax can do this, so Blender will do it!:wink:

All right! So you gonna email him and it will just get fixed, man that is so cool.

Hmmm… I wonder what version he is going to fix it in?

You can also use Blender’s player application to view the “playblast” render. Use the Play button in the Scene buttons window, or you can press Ctrl-F11.

You can get more info at:


(at the bottom of the article)

Great tip, kernond, I hadn’t found that feature yet. I’ll still be using Virtual Dub a lot because I frequently save the playblast as an .avi to cut into the edit in the Sequencer, checking sync with audio. I can also scrub the frames in VDub, handy for examining portions of the motion.

You can scrub the frames in the Blender Player, as well. No audio, though. But, then there’s the Video Sequencer in Blender for more advanced video editing.

Cool! Nice tool, though it’s a bit clutzy having no visible controls like a slider or frame readout. Good for fast checks on action, though. I’ll have to see how I can work that into my toolkit.

Thanks again!

Make sure you have subsurf off.Also, just seeing the wire solid method works in real time.
You can also do an FFMPEG “playblast” with audio.
As far as fixing it, good luck :smiley:

Could you write up a short “how-to” on this? I’d be interested to know the steps. Thanks!

Step 1: add your audio in the video sequencer

Step 2: set your output to FFMPEG : use the H.264 preset
Step 3: go to the audio tab and select “Multiplex audio”
Step 4 : cntrl+click the picture icon
see pics if you need more clarifications on the steps

Attachments







Cool again! Have to give that a go, see how it can work into the workflow. Thanks!

Followed your steps, but got no audio output on playback, either from Blender (PLAY button) nor from VLC (playing the “playblast” vid).

Audio plays fine in the VSE using ALT+A. Picture playback is smooth (if a bit over-compresses), just silent.

Any thoughts?

EDIT: Choosing MP2 or MP3 as Audio codec makes the audio playable in VLC & other external players but still not in Blender using the PLAY button.