Incremental Save

Hi Guys,

On my search for an Incremental Save Addon I found this one:

https://github.com/lapineige/Blender_add-ons/blob/master/IncrementalFileSave.py

and this one:

https://svn.blender.org/svnroot/bf-extensions/contrib/py/scripts/addons/oscurart_tools/oscurart_files.py

The problem I have with the first one is that it only works from incremental 003 on not for 001 and 002 but more importantly the saved file doesn’t reflect in the taskbar saying Blender [C:\Users\ … \filename.004
It always keeps the original filename.

Does anyone know how to make it work?
Or is there a way I can map the default incremental save to a hotkey?

Cheers Christian

There’s a call to store a copy:
bpy.ops.wm.save_as_mainfile(filepath=output, copy=True)

which means a .blend file is saved, but not made active (=copy).

There’s another call to save the current file however, not sure how this is supposed to be used.

if you don’t know it, no one knows it i guess :frowning:

I guess you already know this, but for incremental save in blender you can use Ctrl+S and the ‘+’ on numpad.

yes swene, thats what i’m doing right now.
thanks!

Incremental save in blender has an odd behavior though, if the file name contains any number, it increments that number instead of adding or incrementing a postfix.

paolo

Just add an underslash. File56_1.

Hi actimelvanille.
I’m the author of this add-on.

Are you using the lastest version (1.3) ?
Actually it a WIP add-on, and I need testers. So thanks for you feedback.

I know this method to create an incremental file, but I don’t like it, because you save a new file, with a different name.
But if you have link to this file, you need to rename it by hand or to change all the path each time your do that.
And I think it’s simpler to have you file with no number after the name, and some backcups with that number.

Can you explain me what is your issue with my tool ?

And yeah I see my forgetfulness, I forgot the line to save the current file.
I will correct that.

More, if you want me too add new features, do not hesitate to ask me :wink:

Ok I just made a new version working a bit better: https://github.com/lapineige/Blender_add-ons/blob/master/IncrementalFileSave.py

Can you test it please ? Thanks.

hi lapineige and thanks for the update of your addon!

it works now from 001 on :slight_smile:
in the blender taskbar on top it still doesn’t reflect the file name though.

also it would be nice that if i name my file blender01 the addon makes it blender02 and not blender01_001.
sometimes i name my files like the actual number (e.g. blender16) + a,b,c and then a number again like blender16a01 before i’m happy with my result and go to blender17.
so if the addon would lookup the current filename and just increment the number this would be perfect … at least for me.
just like blender does it when hitting the + key

That will be a bit more difficult, but I will do that :wink:

For, In fact it’s reporting, as you can see in the console and in the info area.
But there is no information in the top bar… I think it’s because I’m reporting before opening the file (after the copy)
I will fix that.

awesome, can’t wait to give it a try :slight_smile:
thanks for the great addon!

Ok I have my code ready, but I don’t know what to choose: do you prefer a new operator, 1 replacing the current 1, or a mix of both (if there is a number, increment it, else create “_001” and after increment it)

A mix of both would be great!
If there is a 1 make it 2,3…
If there is a 01 make it 02,03…
If there is nothing my favorite would be 01,02 without _
:slight_smile:

Ok I have a first (half)working version:
https://github.com/lapineige/Blender_add-ons/blob/master/IncrementalFileSave_v1-4.py

I had not so much time to test this, so if you can test it a lot, in various cases, it would be nice :slight_smile:
I choosed to keep the _ by default, but it easy to change: just replace the line 68 by the following:

output = f_path.split(".blend")[0] + ‘001’ + ‘.blend’

1 knowed “bug” is that if you use something like: MyFile02, it will not generate MyFile03, but MyFile003.

Enjoy, I hope this will work for xmas :wink:

hey :slight_smile:

for some reason the addon doesn’t show up in my addon list.
do you know what might be the reason?

And if you try to install it by hand ?

if by hand you mean copy it to the addon folder then it doesn#t work either :confused:

And it works for others add-on ?

It works for me on Linux and Windows… Strange. Sorry I don’t know what is the problem :frowning:

yes, it works for most … i once or twice had it where i could’t install :confused:
i’m on windows too … blender 2.72b