Index Visualizer No Longer Works Correctly in 2.6.1

Hi All,

I just thought I would report that the Index Visualizer AddOn does not work correctly in 2.6.1, on my Windows XP64 r42722.

Here is how to recreate the error:

Open the default scene and then open User Preferences. (CTRL_ALT-U)
Activate the Index Visualizer AddOn.
Select the Cube and TAB into edit mode.
Yeah, the index visualizer works.
TAB out of edit mode and press CTRL-U (we want the Index Visualizer to always load as part of our default setup).
Exit Blender.
Now re-launch Blender and TAB into edit mode of the default cube.
Boo hoo, no Index Visualizer is present.
Press CTRL-ALT-U and verify the Index Visualizer is enabled and we see that it is.

The Index Visualizer does not show up if it is saved turned on with User Preferences. I don’t know how else to explain it. Can anyone else verify this…?

Here is a picture of the Index Visualizer not showing up but clearly enabled for operation.

Attachments


Hi Atom you know setting: bpy.app.debug = True selected vertices in edit mode can get its index shown
N and then MeshDisplay
(changed lately, a week or so ago even edges and face where numbered correcly, Bl of today not any more ;-( )

The Old script may work but you have to load it youself, my experience, did not check (last year what happens with enable and disable)
will try now … moment

space_view3d_index_visualiser.py from 18.11.2011 works nicely even in save setup.blend :wink:
in Blender W32 Vista from today!

PKHG is correct. The addon has become obsolete, because the functionality has been integrated into trunk.

what does it means that it is in trunk ?

i tested old addon and it does show the vert index at the right location in viewport !
don’t know maya be it is broken ?
SVN 42878

i tried the bpy.app.debug = True
and did not show anything else in viewport ?

does this has to be put inside a script or how ?

happy 2.6

Ok, that is why I mentioned it. So it looks like we need a one-line AddOn to set bpy.app.debug = True. If there is already a checkbox in the Numeric display to turn them off, why do we need to set this behind-the-scenes extra flag? Shouldn’t this just be on by default (meaning the indices viewer)?

I vote that bpy.app.debug = True should be the default. But my guess is that can’t be saved by User Preferences.

Hallo, no I am against bpy.app.debug = True,
First of all it does NOT work as the the script, in the SVN of yesterday ONLY vertices get black small integers.
And mostly: no choice between vertices, edges,faces is (yet???) available.
AND the console gets a lot of debug information I am NOT interested in, if I want to see indices of my mesh.

So it should be a feature ‘better = not in debug mode’ built in or again an addon.

no choice between vertices, edges,faces is (yet???)
Try changing what you are viewing in the 3dViewport. i.e. switch from vertices to edge to faces. You can see the numbers for each.

Setting bpy.app.debug = True does make a mess in the console and leaves the console stuck open until you press ENTER when you exit Blender.

I agree, it should be migrated up to a feature, not left down in the dregs as a debug option.

i got yerteday SVN 43085
and can see the verts index but they are not located at the right place near the verts

they are offseted away from the default cube in this SVN
anybody knows how to correct this ?

happy 2.6

someone should do a bug report for this…

i got this version

'name': 'Index Visualiser',
'author': 'Bartius Crouch',
'version': (2, 6, 9),
'blender': (2, 5, 7),
'api': 36710,

don’t know may not be the latest

let me know if there is a later version
did not see it in latest SVN !

happy 2.6

What a pity, the very good index-visualizer of Crouch does not work … wm_handler problem (seems to be ‘replaced’ to …?)

Or is there meanwhile a System tool to see indices of vertices, edges, polygons?
It is a tool I want to use …

   Peter

i updated the addon: http://www.pasteall.org/38724/python

but you can also use the built-in feature

PyConsole: bpy.app.debug = True

3D View (edit-mode): Properties panel (N-panel) > Mesh display > Numerics: Indices

What indices show is determined by the selection mode

CoDEmanX: GREAT works perfectly. What a relieve :wink:
I tried last year the built-in … but it was then not as nice as the one of Crouch, and now you too!
If I remember correctly, I one got a lot of info, not needed too …, maybe I should check it out again.

Big difference: only vertex indices and in bad readable black, so, if black can be adjusted (how do you do that?)?
So your adjusted Index visualizer pleases me much more … so thanks again for upgrading …