Indigo!

I’ve tried an indigo render of my porche WIP

This is what happened:
All normals are on the right side, my car’s material is blue. my sun is at its maximum. Then how did this happen:confused:
http://dominomf.com/smcfiles/JaccoG_im1162232018.png
five hours of rendering :confused:

Jacco;

send the . blend

maybe Ray mirror is on… turn it off :slight_smile:
edit: You could see it would be black after 10 minutes why wait 5 hours haha

What does the xml file look like (the car material)?

Ian

@framedworld: .blend
@Lekane: I’ll try without ray mirror, I had no time to wait ten minutes Had to rush off somewhere and I just started it for good hopes.
@IanC: its supposed to be blue/reflecting with a noisetexture to fake paint. that ground plane had a normapped-brick texture on it.

edit: IanC: tried turning off the ray mirror on every object. my materials aren’t as they should though. well, atleast the car isn’t black anymore. I should be this way.
http://dominomf.com/smcfiles/JaccoG_im1162302384.png
quick few minutes tryout.

Jacco;

Looking at the xml, you want a phong shader, and you want to play with the colours in it. The black came from having an IOR of 1 on a specular shader (should be much higher).

For a nice black car paint, use the nk data called void.nk. It looks rather nice as a black paint shader. Have you posted over at the indigo forums?

It’s supposed to be blue. Did you try rendering the .blend with blender or yafray?
I’m registring on the indigo forums right now.

Jacco;

I know, but the materials in indigo are rather different so you need to work either with the hooks (read the indigo tut by radiance) to the blender materials or editing the xml.

Edit - I’ve just started a try with a phong material, I’ll post it in a few minutes when the render clears up a bit.

Bing. I changed the reinhard settings to 1:2, to brighten it up a bit. Other than that the scene is the same.

The material looks like this:


<material>
	<name>Material.002</name>
	<phong>
		<diffuse>0.2 0.6 0.85</diffuse>
		<specular>0.1 0.1 0.1</specular>
		<fresnel_scale>0.8</fresnel_scale>
		<exponent>100000.000</exponent>
	</phong>
</material>

http://img72.imageshack.us/img72/6703/carsz1.jpg

EDIT - Hehehe, the black dot is my fault, I must have clicked on the image in gimp accidentally. It isn’t in the render.

Thanks alot Ian, although, the window had to be seethrough and the bar in the front had to be chrome :confused:

Skypa is taking care of it atm over IRC.

Thanks alot people. specialy Ian.

Jacco;

You want a green window?

noooh…
the sides need to be green but the center needs to be clear. nvm I’ve got it fixed. now I need a way to get that material right.

Jacco;

when I try using envmaps (exr maps) I get some sorta disco style:
http://dominomf.com/smcfiles/JaccoG_im1162321154.png

Jacco;

Tis fine!

The exr thing is odd. Which version of indigo are you using, and can you post up the exr?

Ha, I think that is kind of cool, although unwanted. Maybe try something with that.

I’m using this version of Indigo
and These probes.

problem solved btw, the indigo community was very helpfull. I set it to spherical while it should be latlong. I couldn’t have known.

Jacco;

it worked out allright. the indigo community was rather helpfull. yet, My world is grey:
http://dominomf.com/smcfiles/JaccoG_im1162398390.png
[Indigo; 45minutes; .exrmap = pisa]

Jacco;

turned my world colour black. no result, still grey:
http://dominomf.com/smcfiles/JaccoG_im1162732242.png

turned out right in the end:
http://img354.imageshack.us/img354/229/im1162929957nz9.png
Jacco;

Cool, nice pic btw. If you still want the code give me a PM.

You may want to play with the reinhard settings, pre/post and burn. Also, there are some great noise removal tools, there are some threads on the indigo site.

Look forward to a full render!

(oh, and PM me if you need any help, gives me a nice distraction from uni work and domestic problems)

ian