indirect lighting doesn't work with diffuse texture assigned with mix

Like the title says.
Currently I can’t seem to get a material to emit light if there is a texture assigned to the diffuse and I am using Mix as the blend method.

Would be nice if it worked.

You would need to use a proper physically based GI render engine like Luxrender if you want an emitting texture on a non-emitting surface.

Blender’s GI only works with the base material, not the textures, I would be convinced it could be possible to add that to BI as of 2.54 but the shading code is reported to be in enough of a mess and in enough need of a major overhaul and rewrite as it is now.


Would be nice to have it in there.

I was just thinking how it might be useful to fake HDRI by assigning an emit texture on an inverted sphere using the indirect lighting option.

Just use Luxrender. Get a good GPU like a GTX 460, I’ve got one of those, so I can use SmallLuxGPU and it renders a pretty clean image in under 10 seconds. (1920x1080)

Looks like luxrender should be included in the next release.

Does SmallLuxGPU use GLSL shaders at all?

The Luxrender 0.8 branch has something called hybrid mode which basically does the same thing as SmallLuxGPU only with a good chunk of the features in Luxrender and not just working with a subset.

Doug Hammond has done some recent work today on the support for hybrid mode in Luxblend25 so maybe I can now test it without Luxrender crashing.:slight_smile:

Sounds neat. Looking forward to the next blender release so I can get a better idea about Lux.