Indirect Lighting problem in B25

I’m on a scene with a large hangar type building. It will be used to shoot an object hence the camera and object is always located inside the hangar. There are various windows along the top side of the wall and the ceiling. Hence these are the only light sources right now. This also means fully indirect lighting since the hangar is fully closed and no light would reach the inside from the outside.

For this purpose I set the window material to have an emissive value of 2. Yet the scene is totally dark except the windows. I tried enabling “Indirect Lighting” yet still anything is pitch black. I set “Approximate” under “Gather” as mention by somebody else but still everything is pitch black. I also set “Bounces” to 3 but still nothing.

I’d like to use AO on this scene too but AO with “Approximate” looks shit. With “Raytrace” it looks good but I can’t seem to use Raytrace for AO and Approximate for IL.

Is there any way to get blender to light this scene properly using indirect lighting? I played with the thought of using an area light but blender has quite the bug going on there (0.0001 strength and still everything overbright).

Try un-checking traceable for the emmiting material, it is probably the AO that is messing it up. btw, I haven’t seen you around in awhile, good to see you.

I haven’t posted my stuff anymore here but on DA and YT because of “certain people” acting like kids. Anyways…

Tried it also without that option turned on but the result is the same, all black.

Let’s try formulating this a bit different. Has anybody an indirect lighting setup with mesh lights working in B25 (or tutorial wise, no videos if possible as they are impossible to use for various reasons) that I can check out to see where B25 bugs out again?

I don’t know if this is what I mean. I need indirect lighting as the scene can’t be lit properly otherwise. Right now with what I have in 2.5x internal it’s black and I don’t know why (or if 2.5x simply is incapable of it).

Unfortunately when I see these questions, the only answer I can think of is that it can’t be done in a perfectly realistic way because BI does not have a true GI system (even the raytraced version used in Sintel wasn’t entirely based on physical shading in part considering it was working with legacy shaders that did not depend on light physics).

If you really need the appearance of indirect lighting in BI, the best way forward is using gamma corrected, low power area-lamps to simulate it. I know that some don’t like the part of being like a technician in this area, but being one to an extent is the only way to get a rough resemblance of true GI in Blender Internal in many cases.

It’s not required to be perfect GI as the scene is sci-fi anyways. The problem is just that with a fully closed mesh hemi-lamps have no effect. If I could just set the windows (inside) to have an emit value of 1 or 2 and getting the rest done it would be good. For this particular situation even radiosity would be enough as the hangar scene is static except some parts in the middle but these are in a spot light anyways to make it stand out. I’ve seen tutorials mentioning to set the emit value of faces and tick on indirect lighting but for some reason it’s dark. Cranking up the bounces gives a little bit of light around the windows but incorrectly (two faces facing the window, one gets some light the other is dark although otherwise identical). I’m close to use a lamp-per-window hack but this is going to be slow with the many shadows cast all over the place. Well… Maybe a light-map hack would work but I’m using array-ed geometry so this falls flat on the face.

Hemi lamps have no effect?

Perhaps part of the problem then is that you’re using AO set to multiply and it’s either too powerful or the shadowing distance is too high, hemi lamps do not cast shadows so they usually would light nearly everything in a scene.

Exactly that’s the problem. A hemi without shadows is not really useful so AO has to get it down. Since though the room is closed AO takes the beating. What’s most annoying is that every somewhat decent game engine can calculate an AO type global (static) illumination but blender fails at it. Anyways. Tried now using an area lamp for each window along two of the walls (the rest not finished).

This one though already takes over half an hour to render and that’s just 50% render size. Unusable for rendering an animation later on. Maybe light maps would be an answer but I constructed this using array modifiers left and right. I guess I need to full copy that scene once finished and apply all modifiers. Going to bloat the blend file but maybe this way I can get a static GI going which is enough for this particular animation I have in mind.

If the problem is you want atmospheric illumination, but hemi casts no shadows, you might need to replace the hemi with a rig containing a sunlamp and several large arealamps placed far from each end of the scene. It wouldn’t really equate to speedy rendering, but should be faster as you’re using a significantly lower number of arealamps.

Though since this is from inside, you can probably get away with using several sunlamps with extremely soft shadows, as the extra shading boost given using the arealight method wouldn’t be needed as much here.

Tried the sun lamp version but results are catastrophic and totally unusable. The same with the large away area lamps. The only thing that produced something acceptable so far has been the area-lamp per window version as used in my test render above. Just the render time is beyond funny.

If the bad results are anywhere close to being due to brightness and the softness of shadows in the scene, then you may need to tweak the lamp settings to adjust for the fact you’re using multiple lamps for atmospheric lighting instead of a single hemi-lamp.

Otherwise, you might try to see if having any combination of a single area-lamp for more than one window instead of one per-window would give similar results and be faster.

The bad results are not due to the shadow softness or brightness. The problem is that the light/shadow is an utter mess like blender rolling a D20 and shading according to the outcome. Looks like blender totally can not handle the situation of lights outside the building shining inside through the windows (and there is a window… real geometry). Setting the sun lamp to have no soft shadow shows the light spots of the windows on the floor (everything else pitch black) but as soon as you try to make it slightly soft blender goes crazy.

I think your render is pretty good. I crafted quick scene for render like yours using Blender internal lighting. Blender has no radiocity render (well 2.49 has it but that is other story). Ray trace illumination engine is not there. So you need to fake it.

Basic lighting here is the Sun light from outside. When sunlight hits the floor, light bounce up and lights up the interior. So I created array of spotlight on the floor to light up the room:

I guess this could be a possibility. Maybe though difficult to handle once all the props are in there to spice up the place. I’ll keep it in mind though. Any ideas if Blender can do light maps also on arrayed geometry?

Another question. Blender seems to fail at this GI stuff right now (I can get it rendered but 1h per frame for a 1000+ animation is impossible). Is there an external renderer which might jump in to get the job done? It would require GI able to handle the situation above and render in a reasonable time. Blender 2.5 sucks what goes for the GUI compared to 2.49 but in terms of render speed it’s king. I use it right now only to render animations or stills but if the GI is a problem maybe an external tool can help (given it can do it fast enough to be worth it).

I tried now various things that I could think off.

  1. Sun lamp from outside => fail
  2. Large spot light from outside => works partially but fails to properly bounce with indirect lighting
  3. point lights instead of area lights for each window => similar to area lights but although speed is a bit faster it’s not fast enough
  4. Light maps using area lamps for window => fail since blender renders all white (with other words blender fails at light map rendering using “full render” bit time)

Nothing works or when it works it’s way too slow. This somehow annoys me seeing as engines like UEngine have LightMass or other tools which can calculate nice static GI using light maps. Blender really needs something to deal with GI as right now I see no solution to get this done. Annoys me like hell as I had my plans for the scene :frowning:

I think I figured out one part of the problem. In the other blend file (containing the mech to be placed in the hangar) the rendering of lighting works quite well. In the blend file with the hangar though if I render the same mech the colors are totally washed out nearly all the same. Noticed the only difference is “Color Management” under the render panel which seems to be activated by default. Deactivating this brings back the strong colors but not fixing lighting yet.

What’s up with this Color Management crap? Blender needs a REAL HDRR backend and not a pseudo-color correction which is utter fail. Why is this even activated by factory default if it is a big fail and not working at all?

You have to adjust the colors of your materials and lamps to get the strong colors back with color management on (do note the color picker also has the color correction so it should make it easier)

And there are indeed advantages to having it on like more realistic falloff for lights (avoiding a harsh burnout near the source for example)

The problem is that B25 has a huge bug which kills anything CM could send into the field… especially it doesn’t handle HDRR correctly (you need F32 not sRGB… sRGB sucks). The problem is with the various colors you set throughout the scene. B25 “automatically and irreversibly” alters colors nilly-willy which not only makes working with CM impossible it is also incorrect. The color has to be transformed “during rendering” and not “in the UI”. Otherwise the colors you specify are totally wrong if the gamma correction changes between system configurations or if you use linear textures. Having to re-adjust all colors everywhere in a blend file whenever you move it to a different computer and/or monitor is simply unacceptable. Furthermore the output is incorrect as gamma-correction is done at the wrong place.

Besides we really need proper F32 HDRR. sRGB is a poor-mans solution and doesn’t help B25 at all. That said seeing as how the UI is FUBAR I should not be astonished the HDRR is also fake at best. Why not do it right when you re-write code anyways? A pity B25 is going to stay in a SNAFU state for more years to come. Maybe 2.6 is eventually going to do things right instead of “the windows way” U_U