Inflow problem in blender 2.50 alpha 2

Hi Guys, I have a small problem which i hope i can fix. I did a fluid sim in 2.52 using an inflow as a source.

But, at the beginning i don’t want it to produce fluid at full intensity, maybe like 0.2 of it’s normal production. I can’t find a way to animate that.

I tried animating it’s scale, so 0.2 at frame 0 and scale 1 at frame 50 but still, it takes into account only the initial size, so i just get a continuous trickle of liquid.

I tried animating it’s position, at frame 0 to be out of the domain and slowly until frame 50 to reach it’s normal position. Still, nothing, it doesn’t even produce fluid since in it’s position at frame 0 it was out of the domain.

I’m using the default 2.52 blender, from, 64 bit, so a custom build screwing it up is not the case. Do you know how i can change it’s fluid flow during the sim? Thanks in advance

PS: seems i chose the wrong section, can a mod move this thread to support/animation? Thank you

Keyframe the fluid objects inflow velocity settings. You may need a more recent build than the original alpha2 (


i try, right click velocity and insert keyframes but no luck, doesn’t work yet. i cannot keyframe it. I’m trying to find a newer build

Tried in original alpha 2 and didn’t work but did though in r28116

the problem is that on both of my pcs i cannot do a fluid simulation with custom builds.

I have windows 7, all drivers up to date, python installed. Everything works fine in default 2.52, with custom builds i cannot simulate. I press the button and it does nothing.

I have no clue what the problem is, but my guess would be python and the fact that i cannot find a nice install guide on to tell me what version of python should go for each blender release and also if blender cannot find python installed, what can you do to fix that (i have it installed but it still uses the bundled one which comes with the blender install).

Blender 2.5 uses python 3.1, for the 2.4x builds, the python version is on the download page or in the download file name. Are you sure it’s not doing anything. I don’t see any visual feedback when I bake that it is actually doing the simulation but if I Esc the simulation has happened.
I don’t think you actually need to install the full python for the fluid simulation anyway, just what is installed with blender.

well, i know that. But you get the little counter which tells you the progress of the simulation ( as your cursor). I don’t get that with custom builds, nothing happens when i try to simulate.

Could you point me to the 28116 build you used which worked for you? if you downloaded it from somewhere.

Thanks for the help also :stuck_out_tongue:

Ah, got it. It doesn’t show the counter anymore. I can’t see the progress (the counter showed how much more until it finishes) but it simulates and i can animate the velocity. Nice stuff, though if i try to do a high res sim, i don’t know when it’s over etc… Hope they bring back the timer in future releases.

I used 28207 (latest which i could find).

Thanx for the info

try, right click velocity and insert keyframes but no luck, doesn’t work yet. i cannot keyframe it. I’m trying to find a newer build

To keyframe some things in blender 2.5, you can’t right click and choose “insert keyframe”. You need too mouse over what you want to keyframe, and press the I key. (Im using blender 2.5.3).