Inkscape > Blender : Importing .dxf file : not shown circles problem

Hi, I draw a simple drawing in Inkscape which consists of

  1. two circles having different diameters and positions
  2. two tangent lines to these circles

I export it as dxf file with Autocad R12 version compliance. Since I am a new user I can not upload the file as attachment. But I will show it below:


I enabled the Blender addon called import DXF and try to import that simple shape. It imports but only I can see lines, not circles. Can anybody help me out what is the correct way to import circles from dxf to Blender? Thanks.

Edit : Sorry I forgot to add Blender Version : 2.83.5

Welcome :tada:…
You may just use SVG :

and import direcly:

maybeSVG

1 Like

Ok, finally I could import it successfully : by doing :slight_smile:

  1. go to Inkscape and save it as .dxf with Autocad R14 compliance with another name(tangent2.dxf)
  2. while importing to Blender I select those options :

    and successfully import all objects.
    The key problem was the objects and “blocks merge options”. When I choose “By Layer AND DXF-Type AND Blocks” options, import add circles and lines in different layers as blocks. Thanks. Problem is solved.

Edit : While I was writing this answer, I saw that Okidoki did answer my question ! Thanks Okidoki ! Fantastic solution.

So i got curious and exported in Inkscape with R12 version and just imported in blender… it’s there… but it is very very very big (in my example) :grin: … camera is at standard positon less thean 10 m from 0,0,0 and the circle has a dimension of over 130 m… you have to scale the standard cube x100 to touch the bigger circle…

Best method to “find it”: select all (A) and frame all (Home).

lookArThis

Rcently had to import Autocad files(i think a more recent version and the setup that worked was DXF 2018 and ASCII

But, I have not achieve R12 dxf import yet, because not shown circle problem continues in R12 for me. Okidoki can you please share what options did you use while importing R12 dxf?

Yes, same scaling thing happened to mine :grinning:
Thanks.

Just standard… Inkscape 1.2 (drawing.dxf (9.4 KB) ) … save as DXF R12 … Blender 3.2.2 activated DXF Addon (v 0.9.6) … way too big …137m x 136 m … tiny little lamp and camera as seen in screenshot…

Hmm, I try this :

  1. create the same drawing again and save it as DXF R12
  2. open/load the saved R12 file with inkscape but no drawing appeared in inkscape
  3. try save it as DXF R14
  4. load in inkscape and see the drawing.

So even inkscape does not show nothing, Blender shows only tangent lines, not circles! Strange but true, maybe there is a some kind of inkscape export bug… but no error apperead in blender screen.
So, in my case Inkscape version is 1.0.2 (e86c870879, 2021-01-15). There is a problem in my inkscape DXF R12, it does not save correctly somehow. :slight_smile:
Why I am insisted on DXF? It is due to Autocad ! I tried that whether I can open the same file with Autocad, Blender and Inkscape or not.
Thanks.