[Input] Custom Blender Setup | ALT-Maya Navigation, LMB Selections | for blender 3.1

Hi Orange,
I can’t find Simple Lattice on your setup.
I wonder if there is something special to activate?
When I go to addons sections , toggle on/off on simple lattice addon, I got a report error

Is it fixed as you mentionned fixed on your last message ? or should I have something to check?
Thank for you help :slight_smile:

That was the case. Lucky, the addon has been updated in the meantime. Updated with this setup. same link from the first thread.

I’ve noticed that recent builds of Blender have been breaking hotkey mappings. I just downloaded your latest 2.80 setup and installed 04.05.19 build of 2.8, but the hotkeys don’t seem to be mapped to Maya standards (Q: select, W: move, E: rotate, R: scale) but rather the blender defaults. Is this how your setup is or did the newest build break something?


Hey Corey, that is not broken, that’s how it is in the 2.80 incarnation of my custom setup.

I had deviated from my old 2.79 setup a bit.
What you had pointed out is one of the differences, I opted to keep some of the blender defaults there (still weighing it out). Giving the Spacebar a shot instead of QWER. Maybe I’ll make a PieMenu for these, I might even bring back QWER.

But blender is still in beta, so there’s gonna be a bunch of breaking and rebuilding.
As I’m using 2.80 more, I’m noticing all the areas I need to tweak to get it more complete. By the official release, hopefully I’ll have this custom setup pretty polished.

In the meantime, anyone that feels adventurous, feel free to take this for a spin :slight_smile:

Hey 0rAngE! Thanks for the information, not a problem I can map those keys, I just wanted to make sure it wasn’t something with my setup. However, I am seeing some other discrepancies from the latest build versus what is described in the first post. Has something changed?

    • LMB Select (Clears any previous Selection) - Left click on vertices/edges/faces doesn’t select or deselect them. To select/deselect I have to hold Shift + LMB and to deselect anything its middle mouse button.
    • LMB (on empty ) Clears any previous Selection - for me this doesn’t deselect, I have to click middle mouse.
  1. Select More/Less

  • + Select More - this currently isn’t functioning, to grow selection I have to hit CTRL + +
  • - Select Less - this currently isn’t functioning, to shrink selection I have to hit CTRL + -
  • CTRL+ + Select Next Active - currently grows
  • CTRL+ - Select Previous Active - currently shrinks

I’ve installed fresh and renamed my original 2.8 folder, is there any additional setup to be done?

Thanks again for the assistance!

All those are broken hotkeys!, thanks on reporting!

I’ll wrap up the project I’m working on soon, and will update the setup to work with latest buildbots. Probably some time near the end of next week.

1 Like

Is some guide on using this… it’s installed, it looks completely broken, none of the icons for even adding objects into the scene are available… when this is running, if I switch back to default profile for blender things are working… but having this in the blender profile just doesn’t work… aside from the maya -alt style navigation which works… but nothing else…(latest beta 2.80)

Hey Koolio, I’m in a middle of a project that I started, in blender 2.80 none the less. So since I started the project I haven’t updated blender because of the many breaks that happened at that time. So until I wrap up this project, I’m not updating, that means I am not aware of all of the different breaks with this setup and the latest buildbots.

As soon as I wrap up this project, I’ll start rebuilding this setup. Could have a working update some time by the end of this/beggining of next week.

Sounds like there’s been major breaks in the meantime.

ok cool… well I have been using this A Proper Keymap for Blender 2.8 instead now… also has some my much beloved maya style navigation…

given I’m new to blender though and long time maya(past 3dsmax user) I’m really into modelling and well the maya modelling workflow+shortcuts would be great to see in a blender keymap… specifically things like holding down the tab key to paint select verts/edges/faces depending on which mode you are in… would that be something that possible here?

I do have PaintSelect. In my setup it’s MMB … (obviously, as it stands now, only on 2.80 versions older than 4 weeks, as the new ones are broken).

I won’t be mapping it to TAB though, I like having it on the MMB.

Here’s the addon that enables PaintSelect for blender if you want to do your own thing with it :slight_smile:
Ray Cast Selection by Darcviser

Updated the config. It’s now working with latest buildbots.
I’ll have to give it a proper run down next couple of days, many things were broken.

Downlowd link in the first post.

Dear Orange, I did install your update but it destroyed the F zoom to selected object in the outliner so I stayed on the previous update. as I don’t know where to remap it :stuck_out_tongue:

I have the universal final question: Is there a tweak tools like Softimage’s Magic M button Its a combo : I activate the Grab/ move button and I just click and move/drag the selection .
The only way to do that is CTRL+click on my vertex and move. but it’s connected to SNAP option so it’s working but with increment or any snap type choosen.

found a bug on isolate mode: Shift+C doesnt work , but it’s ok for non isolate mode.

is there an official forum to report those kind of bugs?
I know another one about snapping witch is critical , snap on itself(project onto self) dont work after knife ( "2 " shortcut) : to make it back > go to isolate the object > unisolate and its fine.

So many things got broken with those latest blender updates. Oh well …

Fixed the Outliner breaks, there were a couple.

TweakTool, yes CTRL+LMB is cuttently the only way. This used to work flawlessly in my 2.7x setup. This is now very annoying due to changes in 2.80. I’m annoyed by it as well. The mechanics currently are - after invoking the action by CTRL+LMB, you have to release CTRL. Not optimal at all, but I’ve got more then a decade of muscle memory for that action, I’d like to make it work somehow.

SHIF+C is MACHIN3tools addon MACHIN3_MT_collections_pie. Honestly, haven’t used it yet. Checked, and it works in isolate, at least it pops up. Whatever is wrong there, is on the level of MACHIN3tools, probably not my setup.

EDIT: Just remembered, yes that’s a 2.80 thing, you can not move something to a collection if you are in IsolateMode!! Not due to my setup.

The knife tool, I’ll have a look into it today. For some reason, I doubt it’s due to my setup, sounds like a bug.

This thread would be the place to report bugs.
EDIT: Or if you feel like you’re spamming the forum with bumping this thread, you can always PM me!

I’ll note here as well, something I had said a number of times in my 2.7x custom setup thread. This is basically my daily driver for both personal and professional projects. So I depend on this setup a lot. I have completed my first professional project in 2.80 just the other day. Getting familiar with workflows and such. Also scrutinizing my setup. The goal is to have this thing ironed out by official release. There’s gonna be a lot of rebuilds like the one that just happened, but hopefully once the development stabilizes, my rebuilds are gonna get fewer and far between.

Thanks on reporting those breaks, otherwise I catch them on the first next time I use a given hotkey.

Updated the file download, same download link from the first post.


Had a bit of a deeper look into this issue with CTRL+LMB drag. Detirmined it’s a bug actually, reported the bug, and it was successfully fixed. Today’s build from buildbot have the fix, adjusted the keymap to work with the fix. This was affecting the other Tweak CTRL+MMB(drag) as well.
Updated the file

Hi 0rAngE,

I just tried your custom setup for the first time today, thanks for sharing,

I got an error which says

“Menu “VIEW3D_MT_edit_mesh_specials” not found”

Fixed. Thanks on the heads up!

1 Like

seems a bit broken with new 2.8 builds… like no modeling menu

I just downloaded the latest buildbot and tried it out. Can’t figure out what you’re refering to, post a screenshot.

https://i.imgur.com/uMFbH0r.jpg …has the modelling sidemenu on the left side… with your scripts most of it is gone