Inset Extrude addon, can it be updated for 2.6?


I noticed as well as others here on the forum that the Inset Extrude addon doesn’t work in 2.62.
Does anyone know how to update or tweak it to work?

It was a very useful addon. :o

This works for me for the official 2.62 blender

Richard, do you get that one to work alright in the official 2.62?
I get this when installing it.

Pic 1 says broken direct when installing the addon.
Pic 2 shows the errors when trying to use it.

This is the one I have

Attachments (5.99 KB)

Me to, what happen when you select an edge and press “I”?

Just what you’d expect the addon to do

Thanks for making the screencast!

I have confused the Inset Extrude with the Bevel addon.
I was looking for the tools i previous made the insert patterns of a basketball and thought it was the IE addon.
It’s a little dangerous to use tools that are not standard since a few months later when you’ve upgraded Blender a few times you don’t know which tools you’re missing, and the ones you do know few doesn’t work any more.

At least problem solved for me this time, select edges and use the bevel addon to split an edge into two edges… very handy tool :o

This is how i used the bevel addon

You’re supposed to select one or more faces, not edges! Indeed the script isn’t very hardened towards user error, but it does work.

Ah… Zalamander you managed to post the minute after me, so my previous post should have been after yours :slight_smile:

JoS inset-extrude is definitely one of the most wanted add-ons in need to be updated for bmesh.
Hope it will be possible soon(ish).

hey be patient.
bmesh api is being written as I speak.
Please, use 2.62 for mesh addons until things stablize.
There’s no way to rewrite this tool for a week or 2 at least.
Until then, use 2.62, after all, it’s the official release version of Blender.

Sorry to bump this, but did it ever get updated? I find that it doesn’t work in 2.63 either, even the version that Richard attached in his post. I get the following error whenever I attempt to inset-extrude:

Traceback (most recent call last):
File “C:\Program Files\Blender\2.63\scripts\addons\”, line 588, in invoke
self.global_undo, self.mesh, self.island_dicts, self.disp_islands, self.shortest_edge, self.area = initialize()
File “C:\Program Files\Blender\2.63\scripts\addons\”, line 434, in initialize
vert_dict, displace_vecs, shortest_edge, area = run_inset_extrude(mesh, False)
File “C:\Program Files\Blender\2.63\scripts\addons\”, line 303, in run_inset_extrude
sel_faces = find_sel_faces(mesh, individual_faces)
File “C:\Program Files\Blender\2.63\scripts\addons\”, line 28, in find_sel_faces
for face in mesh.faces:
AttributeError: ‘Mesh’ object has no attribute ‘faces’

location:<unknown location>:-1

As it worked fine previously, I’m really hoping this can be updated to support 2.6x and up too.

Use the built in inset tool in blender 2.63, W / Inset Faces
Recent builds will give the mouse drag to interactlively change the inset in the viewport rather than use the slider in the toolshelf

Oh my goodness, I didn’t even know it was added. Looking at

I see it’s supposed to be tied to the I keystroke, but in mine it’s not bound. I can’t find anything under Input > Inset (anything) to rebind the key, since previously that was what the addon was using. Any idea how I bind that function to I again instead of needing to hit ctrl+f and then click Inset Faces?