Inset issue

Hey all,

I’m having an issue with insetting vertices at the moment so I can do an inward extrude…an intrude haha…

Anyway, at first the inset command would only allow for absolute minimal inset (no matter how far my mouse cursor was from center), it also would move the inset very slowly (wasn’t holding shift)…BUT, it was insetting correctly, albeit with above mentioned restrictions. Not sure what I did but now it does this (see picture)

I’ve applied scaled, removed doubles, realigned origin, set cursor to origin, checked Inset settings, I even started wondering if it was because I’m working on such a small scale (another issue of mine in its own right, and may be a question for next project), but I haven’t had issues with any other detail work due to the scale, so I reckon it’s not that.

Here is a pic and .blend file for reference:

Desktop.blend (1.82 MB)



The strange thing is, the two separate faces inset differently…???

I’m guessing I’ve got some setting tuned weird or off/on…Lost out here.

Thanks!

It’s working correctly. The dimensions you’re working at is so small that the default inset value is not small enough and the inset makes overlapping geometry. Make a new inset and move the mouse closer to decrease the thickness value, or adjust it afterwards from the operator panel.

The resulting bevel should be different since the faces don’t have equal proportions.

Thanks for the response JA12!

So my scale reasoning was correct, bummer. I’ll have to find a workaround to get the desired result then, as the inset is larger per instruction. (Blender Guru-Light bulb) …Or I suppose being that its such a small part…inside of the bulb…that will eventually end up hidden by a lamp shade, it really won’t matter how large or small that inset is…I’m ocd when it comes to fine detail, but I’m sure I can get over this one, hah

Is there a recommended setting, or workflow rather, for scale work?

I believe that is a bug. The operator should remember the last value entered into redo and it does when I test it, or it should behave according to the values set in user preferences input section for the shortcut ‘I’. If I don’t move the mouse just after calling the operator it remembers the correct value, but it jumps to incorrect value immediately when mouse interaction starts. This must be a bug in the operator it should start adjusting the initial value, not the default one. It should be reported to the developers if it isn’t already.

You could just replace the functionality with extrude and scale in some cases or you could enter the inset value numerically instead of using the mouse. You can avoid the behavior as well when holding shift immediately after the operator started if you set a smaller value for it to remember in the f6 menu or in user preferences input section for the ‘I’ shortcut.

Yes, i confirm it was not like that before, but i have the same thing since, 2.78c… ( or maybe even one version before ).