Inset?

How can I do an inset operation? Searching the forum I found out that I have to enable the “Inset Polygon” addon from Preferences but when I do that, select a poly and click on Inset from the Toolbar an error message pops up and nothing happens! I’m using the official 2.62 release.

The inset-extrude script is another option. It works perfectly in 2.62 for me
http://wiki.blender.org/index.php/Extensions:2.6/Py/Scripts/Modeling/Inset-Extrude

Thanks but this doesn’t work as I want. Please see the attached image.


When I inset a square polygon everything’s perfectly fine. However, if I inset a rectangular polygon the distance between edges is not the same. It’s doing basically the same as Extrude->Scale which is not what I want.

Whith the “Mesh: Inset Extrude” installed/enabled select all your edges
then press “I” and drag to your liking.
Now you should get the result you want.

Like this :slight_smile:
http://screencast.com/t/L9DBfK1eog3A


I followed your screencast exactly and the result is still the same as before. :mad: One thing I noticed is when I selected all 4 edges the polygon turned orange, not grey as yours. May be that’s got something to do with my results? And why should inset work properly only on edges? Can’t I do inset on polygons? After all, most 3D apps I’ve used allow inset only when in face mode, not edges. Insetting edges is a bit illogical to me?! :confused:

You can do it with the “Mesh: Inset Polygon” addon.
http://wiki.blender.org/index.php/Extensions:2.6/Py/Scripts/Modeling/Inset-Polygon

Like this:
http://screencast.com/t/FkDlw1XpPPP


You scaled your object in object mode. If you want to have the inset work properly, you will have to scale the plane or what ever you are starting with in edit mode, or apply the scale if done in object mode. When you scale in object mode you are making it “look” correct, but it won’t be correct unless your editing of shapes are done in edit mode or applied in object mode.


The top rectangle was scaled in the X direction in object mode without applying the transformation then the inset was added. The one on the bottom was scaled in the X direction in edit mode and then the inset was added. If you apply the scale in object mode to the top rectangle in object mode then do the inset, you will have the same result as the bottom one.

Remember, transformations in object mode are what you want it to look like, but transformations in edit mode (or that are applied using Ctrl-A menu in object mode) are what it is like.

You were right! Scale operations on object level messed up things. I should have done the scale on mesh level. After applying the scale it works now! :slight_smile:

Thanks for that ajm. I never realized why this happened. Thought it was just “the way Blender is”. But after your explanation it makes total sense:

Edit-level transformations are affected by object-level modifications unless those object-level transformations are ‘reset’ to 1 with the Apply function.

Cool.