Installation of Wacom Intuos3 Tablet on Ubuntu

I’m trying to install a Wacom Tablet on Ubuntu.
Two packages are needed namely: xserver-xorg-input-wacom and wacom-tools.
The first package is already included in Ubuntu. So I just installed the wacom-tools package with Synaptic.
My xorg.conf file can be seen below
Next I should outcomment the InputDevice lines with stylus, cursor and eraser.

The problem is that these lines are not present!

xorg.conf (X.Org X Window System server configuration file)

This file was generated by dexconf, the Debian X Configuration tool, using

values from the debconf database.

Edit this file with caution, and see the xorg.conf manual page.

(Type “man xorg.conf” at the shell prompt.)

This file is automatically updated on xserver-xorg package upgrades only

if it has not been modified since the last upgrade of the xserver-xorg

package.

If you have edited this file but would like it to be automatically updated

again, run the following command:

sudo dpkg-reconfigure -phigh xserver-xorg

Section “InputDevice”
Identifier “Generic Keyboard”
Driver “kbd”
Option “XkbRules” “xorg”
Option “XkbModel” “pc105”
Option “XkbLayout” “us”
Option “XkbVariant” “intl”
Option “XkbOptions” “lv3:ralt_switch”
EndSection

Section “InputDevice”
Identifier “Configured Mouse”
Driver “mouse”
Option “CorePointer”
EndSection

Section “Device”
Identifier “Configured Video Device”
EndSection

Section “Monitor”
Identifier “Configured Monitor”
EndSection

Section “Screen”
Identifier “Default Screen”
Monitor “Configured Monitor”
Device “Configured Video Device”
EndSection

Section “ServerLayout”
Identifier “Default Layout”
Screen “Default Screen”
EndSection

My config on Intuos3 on Ubuntu (Hardy) is following:


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "fi"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
EndSection

Section "InputDevice"
    Identifier    "Synaptics Touchpad"
    Driver        "synaptics"
    Option        "SendCoreEvents"    "true"
    Option        "Device"    "/dev/psaux"
    Option        "Protocol"    "auto-dev"
    Option        "HorizEdgeScroll"    "0"
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "stylus"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "stylus"
        Option          "Tilt"          "on"
        Option          "Threshold"     "10"
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "eraser"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "eraser"
        Option          "Tilt"          "on"
        Option          "Threshold"     "10"
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "cursor"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "cursor"
EndSection

Section "InputDevice"
     Driver        "wacom"
     Identifier    "pad"
    Option        "Device"        "/dev/input/wacom"   #USB ONLY
    Option        "Type"          "pad"
    Option        "USB"           "on"                  #USB ONLY
EndSection

Section "Device"
        Identifier  "Configured Video Device"
        Driver      "fglrx"
        Option      "PseudoColorVisuals" "off"
        Option      "OpenGLOverlay" "off"
        Option      "VideoOverlay" "on"
        BusID       "PCI:1:0:0"
EndSection

Section "Monitor"
    Identifier    "Configured Monitor"
    HorizSync 0 - 200
    VertRefresh 0 - 200
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Monitor        "Configured Monitor"
    Device        "Configured Video Device"
    Defaultdepth    24
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
  screen "Default Screen"
    InputDevice     "stylus"    "SendCoreEvents"
    InputDevice     "cursor"    "SendCoreEvents"
    InputDevice     "eraser"    "SendCoreEvents"
    InputDevice     "pad"        "SendCoreEvents"
    Inputdevice    "Synaptics Touchpad"
EndSection
Section "Module"
    Load        "glx"
EndSection

Before editing xorg.conf, be sure to make a backup (cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak) so you can restore the configuration back to old one in case something goes wrong and it doesn’t boot up properly.

You can find more information at https://help.ubuntu.com/community/Wacom and http://linuxwacom.sourceforge.net/index.php/howto/xsetwacom . Latter tool is a part of wacom-tools package and can be used to configure the Wacom buttons.

There is also a graphical tester application you may find interesting. You can find it at http://www.alexmac.cc/tablet-apps/ .

<edit>
Whoops. I forgot to mention that you can edit your xorg.conf using “sudo gedit /etc/X11/xorg.conf”. You can use any text editor you like of course. Remember to make a backup before editing as mentioned above. It’s better to be safe than sure. :slight_smile:

After editing, boot X (shift-backspace should work thought I don’t want to test it now) and it should work.
</edit>

Sorry for the not very informative post, just wanted to stress this point.

Not having a working xorg.conf is really, really annoying.

Thanks BeBraw,

What is the reason that in my xorg.conf files there is no Wacom Input section, while you have 4 of them.
I understood that I only had to uncomment these parts (so they should already be there).

Secondly, if I paste these four sections into my xorg.conf file will that be sufficient?

kind regards,
tony

P.S…: @ IanC, I will definitely make a backup of the xorg.conf file.

Antony41: Yeah. Copying InputDevice sections and the final ServerLayout section without the synaptic touchpad part should do the trick. If you are still unsure about what to do, check out http://ubuntuforums.org/showthread.php?t=25151 . It shows step by step how to get Wacom work.

Thanks again BeBraw,

I’ve made the necessary changes and the X system still works.

So Now I have a second question: How can I achieve absolute positioning, since I still have to use the stylus like a laptop touchpad?

You can add the following to force the correct shape:

Option        "KeepShape"    "on"

You might want to make sure that your ServerLayout is setup correctly. You want the wacom InputDevices to be listed first. If they aren’t added to the ServerLayout, I think the tablet might act more like a touchpad. I know I’ve had that problem before, but I don’t remember exactly what I did to fix it. The ServerLayout section is generally at the bottom of xorg.conf.

Thanks Trevin,

I’m not sure where I have to insert the code (Option “KeepShape” “on”)

In my case the wacom InputDevices are listed before the Server Layout.

Sorry about that. The option line goes in the InputDevice sections for the different parts of the wacom.

Section "InputDevice"
    Driver        "wacom"
    Identifier    "eraser"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"        "eraser"
#    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
    Option        "USB"        "on"
    Option        "KeepShape"    "on"
EndSection

You also need to list the devices in the server layout:

Section "ServerLayout"
    Identifier    "Default Layout"
  screen "Default Screen"
    InputDevice     "stylus"    "SendCoreEvents"
    InputDevice     "cursor"    "SendCoreEvents"
    InputDevice     "eraser"    "SendCoreEvents"
    InputDevice    "pad"
    Inputdevice    "Synaptics Touchpad"

EndSection

The first sections “create” the devices and this section says that they need to be used.

Hope this helps.

Thanks Trevin,

Unfortunately the stylus still has to function as a kind of laptop touchpad. So no absolute positioning so far.

So I think it’s wise to show you my present xorg.conf file below.

xorg.conf (X.Org X Window System server configuration file)

This file was generated by dexconf, the Debian X Configuration tool, using

values from the debconf database.

Edit this file with caution, and see the xorg.conf manual page.

(Type “man xorg.conf” at the shell prompt.)

This file is automatically updated on xserver-xorg package upgrades only

if it has not been modified since the last upgrade of the xserver-xorg

package.

If you have edited this file but would like it to be automatically updated

again, run the following command:

sudo dpkg-reconfigure -phigh xserver-xorg

Section “InputDevice”
Identifier “Generic Keyboard”
Driver “kbd”
Option “XkbRules” “xorg”
Option “XkbModel” “pc105”
Option “XkbLayout” “us”
Option “XkbVariant” “intl”
Option “XkbOptions” “lv3:ralt_switch”
EndSection

Section “InputDevice”
Identifier “Configured Mouse”
Driver “mouse”
Option “CorePointer”
EndSection

Section “InputDevice”
Driver “wacom”
Identifier “stylus”
Option “Device” “/dev/input/wacom”
Option “Type” “stylus”
Option “Tilt” “on”
Option “Threshold” “10”
Option “KeepShape” “on”
EndSection

Section “InputDevice”
Driver “wacom”
Identifier “eraser”
Option “Device” “/dev/input/wacom”
Option “Type” “eraser”
Option “Tilt” “on”
Option “Threshold” “10”
Option “KeepShape” “on”
EndSection

Section “InputDevice”
Driver “wacom”
Identifier “cursor”
Option “Device” “/dev/input/wacom”
Option “Type” “cursor”
Option “KeepShape” “on”
EndSection

Section “InputDevice”
Driver “wacom”
Identifier “pad”
Option “Device” “/dev/input/wacom” #USB ONLY
Option “Type” “pad”
Option “USB” “on” #USB ONLY
Option “KeepShape” “on”
EndSection

Section “Device”
Identifier “Configured Video Device”
EndSection

Section “Monitor”
Identifier “Configured Monitor”
EndSection

Section “Screen”
Identifier “Default Screen”
Monitor “Configured Monitor”
Device “Configured Video Device”
EndSection

Section “ServerLayout”
Identifier “Default Layout”
screen “Default Screen”
InputDevice “stylus” “SendCoreEvents”
InputDevice “cursor” “SendCoreEvents”
InputDevice “eraser” “SendCoreEvents”
InputDevice “pad” “SendCoreEvents”
EndSection

You might try moving the InputDevice sections for the wacom to the top of xorg.conf, right before the keyboard and mouse InputDevice sections.

That is the only difference I see between our two setups.

I changed the order of the sections as you mentioned Trevin. Unfortunately nothing changed.
One thing I have not mentioned so far is that the cursor does not move when the stylus is held slightly above the tablet. I can only move the cursor by dragging.
If I don’t have absolute positioning, must this be a problem in the xorg.conf file?

Try changing


InputDevice     "pad"        "SendCoreEvents"

in ServerLayout to


InputDevice     "pad"

unless you already have it that way.

Many thanks guys,

The problem has been solved!

So far I attached the tablet after booting, because on my Windows machine it will work once you plugin the tablet.
But in case of Ubuntu it appears to be necessary to attach the tablet before booting.

kind regards,
Tony

[QUOTE=;][/QUOTE]
Download Driver From Here

Download New Drivers For Free

Download Driver From Here

Download New Drivers For Free