Installation problem on Mac OS 10.4

Hi everyone, I’m trying to give Blender a try, but I can’t get the application to run! I’ve got a G4 with OS 10.4 installed, and I’ve popped open the .dmg file Blender downloaded in and can’t seem to find or do the right thing to get it running! The instructions are not specific, anyone have any ideas?


Just drag that orange icon to your Applications folder and launch it from there…

Thanks for replying Otto, but I’ve tried that a few times (Dragged all the files in the disk image, or just the orange icon) and it just doesn’t work.

I have no clue why!

I double click on the icon and it tries to launch, then stops…

You can also test some older releases:

The first thing to check is that you have the correct version of Blender. There are specific versions for OS X with Python 2.3 and Python 2.4 on OS X as well as a separate Intel Mac version. I had the wrong version downloaded once and it puzzled me for hours.

If you have got the right version there isn’t usually any trouble getting Blender to start up.

Okay thanks guys, I got it to work! I just needed the Python 2.3 version, maybe they should mention that somewhere…?

Seems to have lots of import/export formats and other things I might be able to use. :slight_smile:

Man you folks rock. I was having the same problem, and the same solution worked for me! :slight_smile: Now to start digging in…


You can get the newer version of Blender to work on OSX, but you need to install a standard version of Python. I had the same problem until I installed my own opy of Python. 2.42a works just fine now.