Installing add-on failed ;/

Hello Blender users,
I’ve tried to install RenderMan Engine on Blender, it is free for non commercial use. When I tried to install add-on from file for a first time, the engine in User Preferences was actually visible, but instead there was some error according to add-on version. so I start to tweak something and I delete the render engine name from the User Preferences list. And now I can’t go back. I tried to install the Engine, install the add on’s, even install the Blender, but even after restarting my iMac, in the User Preferences section the Engine is not visible ;/ Any advice how can I install Render Engine

on Blender?

If you have just downloaded the non-commercial version of Renderman, and I mean recently, the 22.x versions of Renderman do not work with Blender, and won’t for a while. The last version to work with blender was 21.7, which is not available to download any longer unless you bought a commercial version and are able to access it in your account.