installing blender on ubuntu

I formatted my pc, and now cant remember how to reinstall python and blender on ubuntu- I dont want to use add/ remove because the version is old 2.49a I think- can anyone help me here

got the following error when I run from terminal:
error while loading shared libraries: libpython2.5.so.1.0: cannot open shared object file: No such file or directory

Install? You just download it and execute it. Do you need to compile it?

Or do you not know the libs needed for it to run right? You could just install from the repo and then download the latest. I don’t know if that’d ever cause a problem, but it’s been working for a few years for me. If that fails for some unknown reason, the compile instructions are on blender’s main site, but last time I checked it was old. Please tell me we’re redoing the home page for 2.50 (2.6).

Oh, I can guess with a 99% accuracy that python is installed and running on your computer right now. :slight_smile:

Hello
probably you have a different libpython version
Check the one you have in /usr/lib and make a symbolic link to it, ex:
ln -s /usr/lib/your_libpython_here /usr/lib/libpython2.5.so.1.0
It should work!
Bye

thanks for the help- yeah I had python 2.6 running. I installed 2.5 and it worked