Instructions to install CUDA on LinuxMint 19.3 nVidia Driver 435! :)

I have LM 19.3 I have many nVidia drivers available to choose LM19 recommends using Driver-435. So I have that selected. I have nVidia GM204 GeForce GTX970m. I want to enable CUDA so I can use my GPU to render faster in Blender. So could someone give me the steps to do this correctly? Whatever the easiest method is. I’m still new to LM. Thank you for your time! :slight_smile: I really want to avoid any issues with booting lol

MY SYSTEM INFORMATION

System: Host: ColexiumStudios-GE72-6QF Kernel: 5.3.0-40-generic x86_64 bits: 64 compiler: gcc
v: 7.4.0 Desktop: Cinnamon 4.4.8 wm: muffin dm: LightDM Distro: Linux Mint 19.3 Tricia
base: Ubuntu 18.04 bionic
Machine: Type: Laptop System: Micro-Star product: GE72 6QF v: REV:1.0 serial: Chassis:
type: 10 serial:
Mobo: Micro-Star model: MS-1794 v: REV:0.A serial: UEFI: American Megatrends
v: E1794IMS.10C date: 01/07/2016
Battery: ID-1: BAT1 charge: 38.4 Wh condition: 41.4/53.4 Wh (77%) volts: 12.1/10.9
model: MSI BIF0_9 serial: N/A status: Unknown
CPU: Topology: Quad Core model: Intel Core i7-6700HQ bits: 64 type: MT MCP arch: Skylake-S
rev: 3 L2 cache: 6144 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41599
Speed: 800 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 812 2: 808 3: 804 4: 802
5: 802 6: 801 7: 803 8: 800
Graphics: Device-1: Intel HD Graphics 530 vendor: Micro-Star MSI driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:191b
Device-2: NVIDIA GM204M [GeForce GTX 970M] vendor: Micro-Star MSI driver: N/A
bus ID: 01:00.0 chip ID: 10de:13d8
Display: x11 server: X.Org 1.20.5 driver: modesetting unloaded: fbdev,vesa
resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) v: 4.5 Mesa 19.2.8
compat-v: 3.0 direct render: Yes
Audio: Device-1: Intel 100 Series/C230 Series Family HD Audio
vendor: Micro-Star MSI Sunrise Point-H driver: snd_hda_intel v: kernel bus ID: 00:1f.3
chip ID: 8086:a170
Sound Server: ALSA v: k5.3.0-40-generic
Network: Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: e000 bus ID: 02:00.0
chip ID: 8086:3165
IF: wlp2s0 state: up mac:
Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Micro-Star MSI
driver: alx v: kernel port: d000 bus ID: 03:00.0 chip ID: 1969:e0a1
IF: enp3s0 state: down mac:
Drives: Local Storage: total: 1.03 TiB used: 344.10 GiB (32.7%)
ID-1: /dev/nvme0n1 vendor: Toshiba model: THNSN5128GPU7 size: 119.24 GiB
speed: 31.6 Gb/s lanes: 4 serial:
ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB
speed: 6.0 Gb/s serial:
Partition: ID-1: / size: 915.40 GiB used: 172.05 GiB (18.8%) fs: ext4 dev: /dev/sda2
ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-0
Sensors: System Temperatures: cpu: 49.0 C mobo: N/A
Fan Speeds (RPM): N/A
Repos: No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/cuda.list
1: deb http: //developer.download.nvidia.com/compute/cuda/repos/ubuntu1704/x86_64 /
Active apt repos in: /etc/apt/sources.list.d/graphics-drivers-ppa-bionic.list
1: deb http: //ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main
Active apt repos in: /etc/apt/sources.list.d/linrunner-tlp-bionic.list
1: deb http: //ppa.launchpad.net/linrunner/tlp/ubuntu bionic main
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb http: //mirror.os6.org/linuxmint.com/packages tricia main upstream import backport
2: deb http: //la-mirrors.evowise.com/ubuntu bionic main restricted universe multiverse
3: deb http: //la-mirrors.evowise.com/ubuntu bionic-updates main restricted universe multiverse
4: deb http: //la-mirrors.evowise.com/ubuntu bionic-backports main restricted universe multiverse
5: deb http: //security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
6: deb http: //archive.canonical.com/ubuntu/ bionic partner
Active apt repos in: /etc/apt/sources.list.d/ubuntuhandbook1-apps-bionic.list
1: deb http: //ppa.launchpad.net/ubuntuhandbook1/apps/ubuntu bionic main
Info: Processes: 257 Uptime: 9h 12m Memory: 15.54 GiB used: 2.55 GiB (16.4%) Init: systemd
v: 237 runlevel: 5 Compilers: gcc: 7.4.0 alt: 7 Client: Unknown python3.6 client
inxi: 3.0.32

in linux mint you have “additional drivers” programm select nvidia driver from there. if its no driver version you want do in therminal this "
sudo add-apt-repository ppa:graphics-drivers/ppa"
and “sudo apt update” after that you will get newer version of nvidia driver in “Additional drivers”

Okay So I did that. Whats the next step? My Blender needs to catch a Bara-CUDA! lol

Bol shoye spasiba!! :slight_smile:

in blender: edit > preferences > system and select cuda device (you need to reboot after driver installation)

So I did that, In Blender preferences under CUDA it reads: “No compatible GPUs found for path tracing Cycles will render on the CPU”

download or update your drivers from and it’ll work, i had the same problem.

Could you execute this order from the terminal and show me the result?:
cat /proc/driver/nvidia/version

In order to use GPU render with CUDA, you only need to have the nvidia driver installed and use official Blender downloaded from Blender website:

Then you uncompress the tar.xz file to a new folder, you enter that folder and there you execute (double click) “blender” file.
This does not need you to install CUDA toolkit because official build contains precompiled CUDA kernels (Blender installed from repositories does not contain those CUDA kernels)

This is what I get after running this in terminal

cat: /proc/driver/nvidia/version: No such file or directory

That indicates that nvidia driver is not in use.
I know that in Mint you had to follow some extra steps, such as nouveau driver blacklisting. Being based on Ubuntu, I don’t think those steps are still necessary in Mint either.
Give me the output of these commands to see if I can help with nvidia driver installation, but it would be best to ask in Mint forum:
lspci | grep -iE 'vga|3D'

sudo dpkg -l | grep -i nvidia

Please do not try to install nvidia driver downloaded from nvidia site. You always install nvidia driver from the distro repositories.

I’m confused I have Blender 2.80 from the blender official website. And I have fresh LinuxMInt 19.3 install already have nvidia drivers installed and updated:
I have, nvida drivers 387, 390, 410, 415, 440, 435… According to my Driver Manager it recommends 435. So Its selected! However Blender still says "“No compatible GPUs found for path tracing Cycles will render on the CPU?: :frowning:

What I said above, for some reason nvidia driver is incorrectly installed or not being loaded. Give me the output of the previous two orders.

1 Like

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
01:00.0 3D controller: NVIDIA Corporation GM204M [GeForce GTX 970M] (rev a1)

This is the first

ii cuda-nsight-compute-10-2 10.2.89-1 amd64 NVIDIA Nsight Compute
ii cuda-nsight-systems-10-2 10.2.89-1 amd64 NVIDIA Nsight Systems
ii cuda-nvtx-10-2 10.2.89-1 amd64 NVIDIA Tools Extension
ii libnvidia-cfg1-440:amd64 440.33.01-0ubuntu1 amd64 NVIDIA binary OpenGL/GLX configuration library
ii libnvidia-common-435 435.21-0ubuntu0.18.04.2 all Shared files used by the NVIDIA libraries
ii libnvidia-common-440 440.33.01-0ubuntu1 all Shared files used by the NVIDIA libraries
rc libnvidia-compute-435:amd64 435.21-0ubuntu0.18.04.2 amd64 NVIDIA libcompute package
ii libnvidia-compute-440:amd64 440.33.01-0ubuntu1 amd64 NVIDIA libcompute package
ii libnvidia-decode-440:amd64 440.33.01-0ubuntu1 amd64 NVIDIA Video Decoding runtime libraries
ii libnvidia-encode-440:amd64 440.33.01-0ubuntu1 amd64 NVENC Video Encoding runtime library
ii libnvidia-fbc1-440:amd64 440.33.01-0ubuntu1 amd64 NVIDIA OpenGL-based Framebuffer Capture runtime library
ii libnvidia-gl-440:amd64 440.33.01-0ubuntu1 amd64 NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii libnvidia-ifr1-440:amd64 440.33.01-0ubuntu1 amd64 NVIDIA OpenGL-based Inband Frame Readback runtime library
ii nsight-compute-2019.5.0 2019.5.0.14-1 amd64 NVIDIA Nsight Compute
ii nsight-systems-2019.5.2 2019.5.2.16-b54ef97 amd64 NVIDIA Nsight Systems is a statistical sampling profiler with tracing features.
rc nvidia-compute-utils-435 435.21-0ubuntu0.18.04.2 amd64 NVIDIA compute utilities
ii nvidia-compute-utils-440 440.33.01-0ubuntu1 amd64 NVIDIA compute utilities
rc nvidia-dkms-435 435.21-0ubuntu0.18.04.2 amd64 NVIDIA DKMS package
ii nvidia-dkms-440 440.33.01-0ubuntu1 amd64 NVIDIA DKMS package
ii nvidia-driver-440 440.33.01-0ubuntu1 amd64 NVIDIA driver metapackage
rc nvidia-kernel-common-435 435.21-0ubuntu0.18.04.2 amd64 Shared files used with the kernel module
ii nvidia-kernel-common-440 440.33.01-0ubuntu1 amd64 Shared files used with the kernel module
ii nvidia-kernel-source-440 440.33.01-0ubuntu1 amd64 NVIDIA kernel source package
ii nvidia-modprobe 440.33.01-0ubuntu1 amd64 Load the NVIDIA kernel driver and create device files
ii nvidia-prime 0.8.8.2 all Tools to enable NVIDIA’s Prime
ii nvidia-prime-applet 1.0.8 all An applet for NVIDIA Prime
ii nvidia-settings 440.44-0ubuntu0.18.04.1 amd64 Tool for configuring the NVIDIA graphics driver
ii nvidia-utils-440 440.33.01-0ubuntu1 amd64 NVIDIA driver support binaries
ii xserver-xorg-video-nvidia-440 440.33.01-0ubuntu1 amd64 NVIDIA binary Xorg driver

The second output

Apparently you have an Optimus laptop. Do you use it on Windows with intel iGPU as primary card?
I need to see which card / driver is in use, share the output of the following:
sudo lshw -c video

Also, you look in the application launcher menu for Nvidia X Server Settings, then open it and show me a screenshot to see how it looks.

Edit:
Well, the information in your first message seems to indicate that intel iGPU is being used. Anyway you share the information that I have requested.
The downside of all this is that nvidia PRIME (like Optimus for Windows) is not easy to configure for versions of distros that do not include the very new xserver packages. In addition to that in not new versions of Linux distros, the use of PRIME is limited. You may be able to run CUDA while intel is a primary GPU, but applications will not use nvidia OpenGL.
The easiest thing you can do is from the BIOS of your machine configure nvidia Discrete card/PCIe as primary display and disable any option referred to multiple display/multi gpu. This will also disable Optimus on Windows.
The other more difficult option, follow a tutorial to install the latest version of xserver and try to configure PRIME with the latest nvidia drivers.
You see here the second message of the following thread:
https://forums.linuxmint.com/viewtopic.php?t=301410

The steps also require that you create/edit xorg.conf system file as indicated there.

Edit 2:
According to the previous tutorial, Mint 19.3 has the required version of xserver, so that step where “Add the aplattner PPA” is not necessary. You also have compatible drivers already installed. So in theory, you just need to do what is referred to xorg.conf and then after restart the system, configure PRIME profile from Nvidia X Server Settings

*-display UNCLAIMED
description: 3D controller
product: GM204M [GeForce GTX 970M]
vendor: NVIDIA Corporation
physical id: 0
bus info: [email protected]:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: latency=0
resources: memory:de000000-deffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:df000000-df07ffff
*-display
description: VGA compatible controller
product: HD Graphics 530
vendor: Intel Corporation
physical id: 2
bus info: [email protected]:00:02.0
version: 06
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:136 memory:dd000000-ddffffff memory:b0000000-bfffffff ioport:f000(size=64) memory:c0000-dffff

My nvidia settings are blank…Thats never happened before :frowning:

Have you done what is explained in the tutorial from above link about “Create an xorg.conf file” with the content explained there, and then reboot the system?

Hello, random Mint user barging into the conversation.

I’m leaving a note here for others who might be looking at this thread for a solution for the same issue with laptops that have integrated graphics + Nvidia graphics cards, and do not want to necessarily install the nVidia driver 435:

It was not necessary for me to install xorg-server but only to follow this step from that tutorial:

Add the graphics-drivers PPA :

sudo apt-add-repository ppa:graphics-drivers/ppa

followed by
apt update

after that, Open Driver Manager and install the latest available nvidia driver in the list

restart your computer and this problem should be solved.

Previously, the nvidia driver installation failed with an error that said it had missing dependencies, which fixed itself only after I reinstalled mint. (Any less drastic solutions would definitely be appreciated here)

That helped before. Maybe this time too.


My suggestion is that at the same time you ask for support in this forum, you do the same in Mint forum by providing the same information there with the output of the orders that I have requested. So Mint maintainers have a feedback and they see how to make the installation of nvidia driver on computers with Optimus technology easier and automatic when iGPU is selected as the main card from BIOS.