Intel GMA videocard for Windows in Blender 2.5

If you think you are unlucky to have an Intel GMA-powered Laptop, like me, worry no more my friend.

For others, not familiar with the subject: on Intel Video Cards, the Blender 2.5 renders pretty slow, like 2fps or something. At least on my Laptop.
Because under Linux everything looks smooth and crisp, I really tink the GPU power is not an issue, so I started to dig.

Long story short:
In Blender 2.5 go to User Preferences > System > Window Draw Method and change from Automatic to Full

Come back to where you started and want the default startup to look like and press Ctrl+U to save the default setup. Confirm.

Restart Blender and: TADA!

I like your short story ^^
I use blender and linux too, also have intel GPU x4500mhd something like that
so far I have just modelling and rigging + exporting
so I didnt have any trouble, later when I get to render stage and have problem I will remember this : system->draw->automatic -> full ^^