Intel HD Graphics 620 don't work with Eevee

Hi there, I’m creating this thread to try to get together all Blender users that have an Intel HD Graphics 620 because you know, Eevee don’t work for us poor cheap GPU users.
We have this glitch in which every material created in Eevee just looks shadeless black and when we move around the viewport, every pixel redrawn just gests transparent.

I’ve talked to the main developer of Eevee and there’s not much he can do, since he don’t own a HD 620 (wise guy)

In any case our only hope is just wait until the bug reports are open for 2.8, the ones that don’t crash Blender but meanwhile this could be the place were we can share our lame experiences with the 620 and 2.8 and maybe even find a solution, who knows.
Oh and yes, I realize I can be the only poor fellow with an Intel HD 620 so you can just read this post and laugh at my bad luck :persevere:

2 Likes

Guessing Windows, if so you could try linux on a live usb. MESA drivers might work better for this device. Cheaper than a replacement comp. :man_shrugging:

That would be interesting, is it easy to do? can it be installed and booted from an SD card? Although the 620 is a cheap GPU, the computer is not really a cheap device, it’s a Surface Pro 2017, a very cool and convenient machine, which has an SD slot

I’d be interested to hear about the Mac situation as well. Lots of Macs of the portable variety as well as the Mini only come equipped with a range of Intel iGPU’s.

I think Eevee not working fast/usable on such devices is totally understandable but it should render correctly and definitely not crash the application.

I’ll for sure be testing on my Mini (Intel HD4000) when we are nearer to 2.8’s release date.

It does for example properly display scenes in Marmoset Toolbag - an app that looks really similar to what Eevee wants to be - just at significantly lower framerates than on a PC with a proper GFX card.

Well, funny thing is first Eevee versions work well on the HD 620, so I see no reason why it shouldn’t work now. I guess there are plenty of issues with Intel GPUs but as you said @thomas_p, it at least should work. It’s not the case with the 620 where it’s not working even in basic shading mode.
But it’s still early, the developers will be addressing these bugs when they have time for them.

Isn’t that built into the processor? Like the HD4000 and others It’s not a matter of purchasing it, it’s what CPU is present in the box. And trading out a CPU to test some on-chip graphics hardware isn’t going to be high on a developers task list, especially since they likely have hardware suitable to the task i.e. a discrete (but not necessarily expensive) GPU.

I also get the transparent pixel issues occasionally on a gtx 750ti, so it sounds like a general eevee bug, that is exacerbated by the weak gpu.

@SterlingRoth,Oh, I had never seen that bug on anything that wasn’t intel. Could you post an image of the transparent pixel bug?

Here’s a fun one:

the best part is, that triangle doesn’t exist!

I have a gtx 750ti and a quadro k4200

Maybe this fix by Clément for the Intel Iris also solves some of the problems in HD 620?
https://developer.blender.org/rBc924f6f53f13fb55f76b878dbf5d69d60f9d64c2

Try with buildbot build tonight.

1 Like

Depends on the BIOS and hardware capabilities. You’ll have to access the BIOS with a key press at boot and then check what else you can boot from. SD cards are bootable on supported systems.

1 Like

I have nothing helpful to add (unfortunately), but I thought I would just say that I am also experiencing this problem.

I primarily use Blender with a desktop computer with an Nvidia graphics card and 2.8 and EEVEE works fine.

I also, however, have a laptop with Intel HD Graphics 620 for using Blender when on the go. EEVEE doesn’t work on that laptop. Everything is drawn transparent, except for a black square in the middle of the object. It is not usable.

i am using Windows 10. Intel driver version 23.20.16.4973 (which I believe is the latest).

I have the same problem with my i7-8700k (intel graphics 630).
I can afford a graphics card but I’ve been waiting for the release of the new Nvidia GPU which is why I have been putting off buying one.

Too bad because I’ve wanted to try it out on my newest character model with eevee. Hopefully a developer will address this soon.

I’ve got the top-end Surface Pro 2017 too, definitely not an old or weak machine and have unfortunately had the same issue since the start of 2.8. I have the Intel® Iris™ Plus Graphics 640 which has OpenGL 4.5 support.

Interestingly, a recent-ish build of 2.8 allowed the Workbench viewport to work, but Eevee viewport still just draws all objects as black when first loaded, then draws the background colour over newly exposed areas when the viewport is moved.

Interestingly, I attempted to fix this with a driver update for the iGPU from Intel, but instead of fixing Eevee, it stopped 2.79 from working at all - the entire screen draws the default ‘blender grey’. It seems to be due to an OpenGL issue, since running it with software OpenGL works properly, if only at about 0.3fps.

I am not too concerned yet, since they said support for more GPUs was still being worked on, but it is unfortunate that the only functioning version of Blender I have doesn’t really work.

Just to say, this is a good suggestion and does indeed work (at least for me).

I installed Ubuntu and Blender 2.8 EEVEE works just fine…!

I guess changing your operating system is a bit of a radical solution to the issue… but hey - if it works - it works.

I would like to install Ubuntu on my Surface SD Card, but I don’t know how to do it, I’ve tried the pen drive installation that let’s you test it without installing it but blender and some other apps just stop working and it freezes the Surface.
We may be out of luck if its a Windows only problem, I hope not though and developers will address the intels HD 600 cards somehow

When beta version of 2.8 is released and it is possible to report problems, if this problem continues you can report it so developers can check if this is a Blender problem in Windows, or intel driver in Windows problem.

Tried upgrading your drivers there from the package manager or terminal ( Ctrl Alt T generally ) ?

Do one line at a time top to bottom:

(optional) add a ppa for specific mesa packages
sudo apt-get update
(optional) sudo apt-get upgrade
sudo apt-get install mesa_package_name_goes_here

This will be temporary (works until shutdown) unless you’ve set up persistence on your pendrive / SD card. I wouldn’t advise to install on / touch your Windows drive until you’ve grokked partitioning / dual boot / etc, and the risks to that system.

Excuse my noobness in Linux @LoboTommy , but how would I do that?, I mean everything but more specifically the persistence on my pen drive? does that mean what I’m thinking, that is, once activated I dont have to set up everything again, from wifi passwords to downloading Blender again?
Thank you!

Live Pendrive/Memory is only used to install Linux, or as a rescue system, or to do some tests. But this is not stable system and is not to be used in production, this usually brings problems even when it has reserved space for persistence data.