interactionOps [iOps]

Hello again,

I’ve installed V2.1.2 and the issue hasn’t been solved. I also checked on the console log to see if anything changed. There are no changes in the log. It’s the same logs mentioned in my previous post.

That works without any problems. Before the issue shows up, I once have to change the hotkeys in the preference and don’t even press “save user hotkeys”… Only Save preference. When I opened the Blender again, there were no changes in the hotkey, just the same as before. Strange. :thinking:

EDIT:
I ran a quick test and It was very interesting.
There was nothing wrong with your addons, the problem is Machin3Tools who have caused this issue. it’s the reason why the issue showed up. The issue no longer show up when Machin3Tools is disabled.

Hi, try to re-install machine tools

Yeah, I’ve tried to do that. I even re-download the file from the official website of Machin3tools to do a clean installation.

It’s still the same result.

I’m trying to understand, Could you call Machin3Tools shading pie(‘Page UP’ shortcut) and move your mouse pointer over smooth and wait for a tooltip with an operator name:


and maybe you have to enable this pie in Machine3Tools preferences. And let me know what you have there.

I understand now. Interesting. The problem is indeed within Machin3Tools. It’s because “Shading Pie” was disabled which is what caused the problem. :thinking: I run a few tests and confirmed it. I can also mention this:
if Machin3Tools was disabled, and IOPS was working properly as wee. This is confirmed.

Well, the mystery has been solved.

EDIT:
i did a bit more of investigation because I noticed a few things.
Here’s 2 pictures:
1-Example

2-Example

If you look closer, then you should able to notice the difference between these 2 pictures.

The first photo is with Machin3Tools disabled (Edit: replaced no machin3tools enabled)

The second photo is with Machin3Tools enabled (Edit: replaced disabled)

1 Like

Cool so, I will make a fix for this. Thank you.

huh. I made a mistake

what I meant to say is:

the first photo is without machin3tools enabled

the second photo is with machin3tools enabled

:man_facepalming:

Btw, you’re welcome and glad I could help out

1 Like

So i have been updated iOps pie menu - now it checks MACHIN3Tools shading pie enabled or not. Thank you.