Interface totally messed up

I’m on Fedora 9 and have a big problem with the interface.

Sadly my nVidia card overheated and burst many of it’s components, so I had to switch to using the on-motherboard graphics card (from lspci):

Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 04)

Eventually I’ll get a new graphics card, but for now I’m stuck with this one. The blender interface is now totally messed up.

If I don’t enable international fonts, all the text is un-readable. If I do enable them, the text looks a tad ‘blury’ and all the little icons in the pull-down (up?) menus are missing.

Any ideas?



I am not sure if this will help but:

If the textured font button is active, try deactivating it.

Also its a bit unlikely to work but sometime if you turn off the advanced theme settings (right click on computer icon and select Properties > Advanced System Settings) and also going back to a classic windows theme may help.

On some display drivers, it is possible to adjust the amount of hardware acceleration, if you driver has the option, try tweaking the settings).

With the ‘Textured Font’ button deactivated I get no text in the buttons at all.

I’m on Linux, so the advanced theme settings workaround is not applicable.

The result from doing

Compiled with Python version 2.5.2.
Checking for installed Python… got it!
GL Vendor Tungsten Graphics, Inc
GL Renderer Mesa DRI Intel® 915G GEM 20080716 x86/MMX/SSE2
GL Version 1.4 Mesa 7.3-devel

Interestingly, on quitting, I get this:

/usr/bin/blender: line 54: 3270 Segmentation fault /usr/bin/blender.bin $@

Unless someone has some more ideas, sadly it looks like I’m stuck without Blender for now :frowning:

Since I have a project to complete by the end of the week that needs some relatively simple 3D, I’m going to have to learn another program real fast, can anyone recommend a good alternative 3D program for Linux?

Oh if you’re on linux (I’m on fedora 10), you maybe have a few more options.

(Though all of these options disable hardware accel features in blender, so things go a bit slower in the 3d viewport but rendering still works. Also the game engine and glsl support will probably not work either.)

First option is to try the static version of Blender for linux, which is available on the Blender site. (This uses a software version of OPENGL and often can work)

Second option is to disable hardware accel in Xwindow entirely.

In my xorg.conf file I add this line when i wish to disable hardware accel in the video card section of my xorg.conf:

Option “NoAccel” “True”

This probably only works for fedora 9 and below and like i say
will make Blender Slower to update in the 3D view port.

On fedora 10 there is no xorg.conf file so one needs to me made
(do a google seach for fedora 10 xorg.conf) for how to make one
if you need to add the NoAccel option.

Also if you linux box has the 3d effects window manager options like compiz active or beryl disable them. They don’t play nice with Blender often.

Failing all that have you tried an svn version with debugging
this may run. Try for some downloadable versions.

Hope this helps.

I’m on Fedora 9 / Rawhide, so do have an xorg.conf file.

Option “NoAccel” “True” fixed it! You rock, thanks man :slight_smile: