Internal Render, no mip maps / anisotropic filtering

When clicking render, blender never uses mip maps. I’ve never got it to work. I have use mip maps enabled and I am using my textures as materials. How do you turn it on? Even in the newest version of blender, I still can’t get mip mapping on so all my textures look horrible when rendered at distances.