Interpolated hair particles super small

I’m using hair particles to instance trees for a large forest. However, I’ve found a problem with using Interpolated children.
Some child particles end up extremely short/small, resulting in an instanced object something like 1/4 to 1/8 the size it’s supposed to be, with no way to control if and how often it happens.
Attached screenshot below:



Edit: Interestingly enough, this doesn’t appear to happen when I turn off the texture affecting Density.
The texture only modifies the Density parameter, though. Doesn’t touch Size, Hair Length, or anything that should be related to hair length.
Huh.

1 Like

Okay. I’m not sure if this is considered a bug or a weirdly missing feature…
How the heck do I control the density of child hair particles WITHOUT affecting their size?
The particle density parameter appears to have zero effect on the spawn rates of Interpolated children, but act as the Length parameter for them instead.
If I turn on Long Hair for them, it solves the tiny children problem, but instead introduces a super splotchy boolean-ish popping, where it looks like it turns child particles on/off for an entire parent hair instead of doing anything even vaguely resembling a gradient.