Intro to Rigging and Drivers (3-part video)

I just completed a video tutorial on creating a bouncy-ball rig in blender 2.5

It is a good introduction to rigging a simple object for animating, and using drivers to automatically simulate things like squash-and-stretch. I split the video into 3 parts so it can be viewed on youtube, and it’s in HD so you can see all the settings.

The first part is - - and the other two parts are linked from it.

Enjoy, and hope it helps.

Thanks, I’m gonna go watch it.

very nice tutorial!
one thing: when i opened up your BouncyBallRig.blend in a recent build of blender 2.5, the verts in the BouncyBall objects are all squished into a line on the y-axis. like this:
but when opened in Blender 2.5 Alpha 2(rev. 27226) from, everything is fine. just thought you should know, something must have changed from Alpha 2 that is causing some weirdness.

and a question: don’t you need to add the same kind of driver to the Y scale as you did for the X scale, so that the ball will spread out in both dimensions when it gets squished?

edit: re: recent build problem
i just tried appending your scene into a new file and everything comes in just fine.
thanks for the tutorial and example file!

@treaktor - thanks! and wow, that’s a weird bug. i’ve only been using the latest release so i didn’t run into that. dunno why that’s happening…but good to know it’s alright in alpha 2.

and a question: don’t you need to add the same kind of driver to the Y scale as you did for the X scale, so that the ball will spread out in both dimensions when it gets squished?

nice catch. i guess i missed that only working from the front view. but yes - i’ll need to fix that in the file and the video. thanks!

Hey, I responded to your YouTube video, but I figure other people might benefit from the solution here as well- if we can figure it out.

I have followed your videos through the second one, however I run into a couple of problems. After I set the drivers for the X and Y rotation controls, my sphere automatically adjusts 90 degrees in both axes respectively.

Here’s the bigger problem: when I set a driver for the lattice in Z scale and make ANY adjustment in the drivers window, the lattice scales down to zero in the z direction flattening my ball to 0 as well.
What am I doing wrong? I am sure it is very simple.

Just thought I should mention - the problem is not just when the driver is affecting the scale in Z-axis, but when I add a driver to the Y and X axes as well.
Ugh… I can’t figure this darn thing out.

it would help to take a look at your .blend, but as for the first problem it sounds like the control meshes are already rotated, and so when you apply the drivers the ball will rotate how the control meshes are rotated. try this: hit “N” and check the XYZ rotation of the control meshes (object mode).

i can’t tell what’s going on with the lattice problem. in the driver panel, if you check “show debug info” what does the driver value read as? 0.00? try hitting “update dependencies” too. but again, i could probably troubleshoot it better if i could play around with your setup.

Hey jason, thanks for your reply. I thought it could have been that when I parented the sphere/ball to the lattice, I parented to the object and not ‘lattice deform’, however that was not so. I am still unsure of why it is not working correctly, so I am just going to start over and I’ll let you know how that goes.

Alright, so the rotation is working fine now - thank you - however when I add a single driver to the z-scale on the lattice and add any variable to any variable type (distance, transform channel, etc.), the sphere flattens to zero again. I have attached some pictures - do you see anything wrong with the setup?


ok it seems like some sort of buggy thing because in the last two screenshots, since the scripted expression is set to 1.000 the z-value should be 1.000 right? did you try hitting update dependencies?
also checking “show debug info” shows what the current value of the driver is, so see what that is. if that’s at 0.000 then something’s wrong…if things seem to reset, click update dependencies again.
so what happens when you change the scripted expression value to “var” (or whatever you name your distance variable as)?

(ps i’ll be gone all next week without internet so i hope you can figure it out, or someone else can help. i’ll try to remember to check this again when i get back)

Hey thanks for the quick reply. I tried numerous times (as if it would work the second, third and fourth time :wink: pressing 'update dependencies - not the solution.
I also tried clicking ‘show debug info’ - but it read zero, which is not good.
The name makes no difference, I don’t think but I will try to change that once again and see what happens. This is just a mystery… thanks for the help. Any other ideas?

well if it’s a scripted expression the name would matter.
did you figure it out since last time? can you use rapidshare or something to upload the file? i have no idea otherwise why it’s buggy for you.

hi, i’m just begining with rigging and i was wondering if anyone here can do me the favor to upload the file hank for rigging.blend, cause i dont have the disk where all those files to make the tutorials are. thanks for your responses.

Great Jason.
Very helpfull tutorial! :wink:
It won’t make long before being used!! ;D