Intsalling Yafaray

Ive got some questions about installing Yafaray,

On the Yafaray website it says you need Python 2.62 installed

Howerver Blender 2.49 needs Python 2.5 installed

Ive tried it with both versions of python, this is what happnes when i click the Yafary exporter button
Version 2.52 , i am told that i need the python26.dll
Version 2.62 I get an error saying , “no module named platform”
Both Vertions installed at the same time, I get the an error saying “Module use of python26.dll conflicts with this version of python”
Any help will be gratefully recieved

Blender 2.49a(for Windows) is built with Python 2.6.

If you are using the latest 0.1.1 version of Yafaray you need Python 2.6. You also need to make sure both Blender and Yafaray run on the same version of Python. So for Blender 2.49a and Python 2.6 you need Yafaray 0.1.1 for Python 2.6.

If you are using an earlier version of Blender you need an earlier version of Yafaray that runs on Python 2.5

Also make sure you have the 32 bit versions of Blender and Python if you are running a 64 bit system, as there is currently no official 64 bit version of Yafaray for Windows.

Make sure you uninstall all previous versions of Yafaray and the Python scripts before installing a later version as the scripts are set up differently.

If you have any other problems try here:-

Thanyou Sooo much , i didnt realise that i only had 2.49 and not 2.49a , thanks again

Thanks Organic - I was about to ask the same question. I have both Python versions 2.5 & 2.6 on my machine at work (2.5 for old Yafraray install) and Blender 2.49a always boots up saying “blah, blah…built with 2.5…Got it!”

Not sure if that’s an issue cuz I haven’t tried (ugh) installing the new version of Yafaray.