inverse kinetics rigging problem


So I’m trying to create a rig for this model’s arm.
After setting the pole target to the Armature, the arm refuses to bend.

BEFORE ASSIGNING POLE TARGET

AFTER ASSIGNING POLE TARGET

(why you no bend?)

The arm is supposed to keep bending while facing the floating elbow bone.

WHAT’S SUPPOSED TO HAPPEN AFTER ASSIGNING POLE TARGET


(see 8:24-8:31)

Here is the project file. The pole target is already assigned. Someone please help!

Okay just taking a look at your Rigg…

1st I turned on X-ray… (that makes things much easier to see)
With your Rigg selected > Goto Attributes panel. > Armature (the man Icon) > Display > check “X-Ray”…

2nd in that same box… > check “Axis” to display the individual Axis of your bones…
(this helps with Rotations) (the Axis on an Arm should align…) (if not your get goofy behaviors)

3rd Right off the bat… with your fore arm selected if I Tab into Edit mode I see that your fore arm and upper arm Axis are not aligned… the Upper arm has Z Axis up and the Fore Arm has X Axis pointing up… you need these to be aligned…

Select your Fore Arm in Edit mode… and in the Right hand tool bar under “Transforms” find the Roll slider… and set it to the same Roll as the Upper Arm … (which it looks like it is set at -90 degrees)

That alone however won’t fix the problem…

4th With the ForeArm Selected TAB back into pose mode and find in the attributes panel the bone menu (bone icon)
look for Inverse Kinematics… go there and lock off the Y and Z Rotation channels as you want the elbow to only bend on the X axis… (in this instance)

5th When ever you first create a joint that is going to have an IK constraint placed on it… you absolutely ‘must’ but a slight bent at that joint or else the IK solver can’t decide which way it is to bend…
so TAB into edit mode and move the elbow joint back just a little bit to give it just a slight bend…

6th goto the Bone Constraints Attribute panel… (the bone and chain icon) and there under your IK constraint you will find the “chain length”… Set that to 2 as you only want the IK to effect 2 bones… the forearm and the upper arm… with it set to zero it effects “all” bones… (which is bad… most of the time)

7th While you are in the IK constraints panel note that you might need to adjust the Pole Angle… try setting it to -90 degrees and see if that works better…

8th always remember to adjust the size and position of your bones in edit mode… (and do all your animation in Pose mode)…

9th always remember that when you are in pose mode you can use the Alt+S, R, or G key to return any bone into it’s original postion…

thank you!

Good Deal… Blender on dude!